deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Update dependencies, .gemspec Gemfile
Date Thu, 01 Sep 2011 16:00:51 GMT

First shot at fixing the dependency situation. Basically, .gemspec is now a self contained
with everything you need to actually run deltacloud (including the cloud provider gems). Gemfile
now includes the gemspec, and adds the dependencies for developers. I like the division: 
.gemspec is 'runtime' and Gemfile is 'development'.

I ran into some issues with versions. The actual problem is that I'm on ruby 1.8.6. It seems
more and more things are dropping 1.8.6 support either explicitly or just cos not many people
are using it any more? (question, not statement). This may be a seperate discussion but the
question is: 'are we still supporting 1.8.6?'. If we are, then the version constraints (explained
below) are relevant. If we aren't then I will revisit the versioning and then we need to explicate
the use of ruby 1.8.7 in the .gemspec and documentation (currently gemspec says '1.8.1'...).

* s.add_dependency('nokogiri', '>= 1.4.3', '< 1.5.0')
Installing nokogiri (1.5.0) /usr/lib/ruby/site_ruby/1.8/rubygems/installer.rb:164:in `install':
nokogiri requires Ruby version >= 1.8.7. (Gem::InstallError)

* s.add_dependency('rack', '>= 1.0.0', '< 1.2.1')
/usr/lib/ruby/gems/1.8/gems/rack-1.2.1/lib/rack/utils.rb:138:in `union': can't convert Array
into String (TypeError)

* I added this to the Gemfile: gem "linecache", ">= 0.3", "< 0.46"
of this wonder:

*gem "rspec", "< 1.3.1"
===> because rspec has/is dropping support for 1.8.6 altogether


View raw message