deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Toby Crawley <tcraw...@redhat.com>
Subject Re: issue with aws gem v.2.4.0 (latest) used by ec2 driver
Date Mon, 17 Jan 2011 17:26:51 GMT
I've submitted a patch for the issue, please vote for it: https://github.com/appoxy/aws/issues/#issue/47

Toby

On Jan 17, 2011, at 12:01 PM, marios@redhat.com wrote:

> Hi, whilst trying to catch up with the project I came across an issue with the latest
version of the aws gem (2.4.0) which is used by the ec2 driver... running deltacloudd -i ec2
gives:
> 
> "
> #
> /usr/lib/ruby/gems/1.8/gems/aws-2.4.0/lib/awsbase/awsbase.rb:33: undefined method `require_relative'
for Aws:Module (NoMethodError)
> #
> from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
> #
> from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
> #
> from /usr/lib/ruby/gems/1.8/gems/aws-2.4.0/lib/aws.rb:18
> #
> from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original
> "
> 
> Toby is going to poke at appoxy for the fix, so in the meantime you should use aws v.
2.3.34 (thanks Toby) if you happen to be installing aws for the first time etc  ... "sudo
gem install aws -v 2.3.34",
> 
> 
> marios

---
Toby Crawley
tcrawley@redhat.com





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message