deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Fojtik <>
Subject Re: EC2 driver rewrite (rev 2) + Tobi patches
Date Mon, 29 Nov 2010 11:22:13 GMT
On 26/11/10 18:03 +0200, wrote:

>It looks like the 'EU' and 'US' regions are supported for creating 
>buckets. However, things start blowing up when you try to specify the 
>'asia pacific' or the 'us-west-1' endpoints (see


Yes, thanks for reporting this, I found an issue in aws gem that converting
location string to upcase, which unfortunately breaks other regions than

Pull request:

>With risk of this last point being overlooked - I propose that we 
>split this patch-bomb (nuke?) into its constituent parts - for sure 
>the new ec2 driver warrants its own stand-alone patch.

Yes, that is a good idea. I already took all 'non-EC2' related patches
and pushed them into master.

This also includes Tobi client modification. I'll rebase this patchset,
remove applied patches and resubmit it again.

Anyway big thanks for testing out this patch!

   -- Michal

>On 25/11/10 12:25, Michal Fojtik wrote:
>>On 19/11/10 13:39 +0200, wrote:
>>>Theres too much going on in this patch series - I specifically looked
>>>at whether the new gem and/or new driver breaks buckets (and wanted to
>>>check region support but couldn't get that far).
>>>I cannot get a bucket listing - looks like its a problem with the aws
>>>gem (tried through irb and am getting the same result). Michal you
>>>already said that this works for you but it seems Toby had the
>>>same problem as me so not sure what's going on.
>>>Trace looks like:
>>>irb(main):013:0> s3_client.buckets
>>>#<ArgumentError: wrong number of arguments (2 for 1)>
>>To better clarify this, this bug exists for Ruby version <= 1.8.6.
>>So Fedora 13 is affected with this bug (and RHEL5). Anyway, Tobi's patch
>>should fix this problem, lets wait for appoxy guys.
>>Btw. meanwhile I tested S3 region support under 1.8.7 and seems like it
>>irb(main):011:0> s3_client.bucket('mfojtik-awesome-bucket', true,
>>'public-read', :location => :eu)
>>Closing HTTPS connection to
>>Opening new HTTPS connection to
>>=> #<Aws::S3::Bucket:0xb6f81928 @creation_date=nil,
>>@name="mfojtik-awesome-bucket", @s3=#<Aws::S3:0xb6fa5ad0 </snip>
>>-- Michal
>>>Request was: -none-
>>>Response was: -none-
>>>ArgumentError: wrong number of arguments (2 for 1)
>>>from /usr/lib/ruby/gems/1.8/gems/aws-2.3.26/lib/s3/right_s3.rb:83:in
>>>from (irb):13
>>>On 15/11/10 14:46, wrote:
>>>>So in this patchbomb you can find all previous EC2 patches and Tobi
>>>>applied on top. This patches should be applied on top of master.
>>>>- Fixed/Updated cucumber features
>>>>- Added 'state' to Key
>>>>- Added Cucumber features for storage_volumes
>>>>- Refreshed Mock data
>>>>-- Michal

Michal Fojtik,
Deltacloud API:

View raw message