deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ed Bradford <>
Subject Re: 'A Blob by any other name'...
Date Thu, 26 Aug 2010 15:49:58 GMT

I'm brand new to this discussion. I like Blob and don't mind "bucket".
"Collection" has so many class implementations that it is bound to be
Same for "Container".

Instead of "bucket" we could use:

  cask - I like this one
  kettle - I like this one also especially for a "blob"

 Windows Developers Newsletter Archive:  
 VISTA White Paper:                      

T/L none; Outside: 1-512-636-1853 FAX none

             Michal Fojtik                                                 
             om>                                                        To 
             08/26/2010 07:22                                           cc 
                                       Re: 'A Blob by any other name'...   
             Please respond to                                             

On 26/08/10 08:13 -0400, Tomas Sedovic wrote:
>Hey Marios,
>I'm for keeping the word "blob". Every dev already knows what that is --
it's used in databases, git, et cetera.
>However, I don't like "container" as much. If I just saw the two words
without a context, I would perhaps consider them synonyms (blob ==
"container for bits").
>My suggestion is "collection", if you can afford such a general name. In
my mind it's much clearer that blobs form (or belong to) collections rather
than containers or buckets.

I don't want to 'troll' or something, but I'm not very sure about
term 'collection', because we already using it in API.
So to avoid confusion in terms, I'm voting for 'bucket' or 'directory'.

  -- Michal

>----- Original Message -----
>From: "" <>
>Sent: Thursday, August 26, 2010 11:29:59 AM GMT +01:00 Amsterdam /
Berlin / Bern / Rome / Stockholm / Vienna
>Subject: 'A Blob by any other name'...
>Hi, I have so far been using the nouns 'Container' and 'Blob' for the
>entities in our (developing) cloud storage API. It was always the
>intention to change these at some point so I thought it would be a good
>idea to get some input from the wider group. A 'blob' is a uniquely
>named collection of data, stored as a single entity (in S3/CloudFiles
>'Object'). A 'container' is a uniquely named grouping of blobs (in S3
>'Bucket' and CloudFiles 'Container').
>So, any ideas about what we should be calling these 'things'? Do we need
>to change the current names at all?

Michal Fojtik,, +420 532 294 4307
Ruby / Ruby On Rails Developer
Deltacloud API:

  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message