deltacloud-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mfoj...@apache.org
Subject [4/4] git commit: Core: Lock sinatra and tilt to versions known to work
Date Tue, 12 Mar 2013 17:31:20 GMT
Updated Branches:
  refs/heads/master 4cf2040ad -> e961458ae


Core: Lock sinatra and tilt to versions known to work


Project: http://git-wip-us.apache.org/repos/asf/deltacloud/repo
Commit: http://git-wip-us.apache.org/repos/asf/deltacloud/commit/e961458a
Tree: http://git-wip-us.apache.org/repos/asf/deltacloud/tree/e961458a
Diff: http://git-wip-us.apache.org/repos/asf/deltacloud/diff/e961458a

Branch: refs/heads/master
Commit: e961458ae2bb8579ee1aa01c666ccaf65e9ef032
Parents: 3f81416
Author: Michal Fojtik <mfojtik@redhat.com>
Authored: Tue Mar 12 10:53:25 2013 +0100
Committer: Michal fojtik <mfojtik@redhat.com>
Committed: Tue Mar 12 18:30:08 2013 +0100

----------------------------------------------------------------------
 server/Gemfile                 |    2 --
 server/deltacloud-core.gemspec |    9 +++++++--
 2 files changed, 7 insertions(+), 4 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/deltacloud/blob/e961458a/server/Gemfile
----------------------------------------------------------------------
diff --git a/server/Gemfile b/server/Gemfile
index 5f3c98d..7ac1b25 100644
--- a/server/Gemfile
+++ b/server/Gemfile
@@ -2,8 +2,6 @@ source "http://rubygems.org"
 
 gemspec
 
-gem 'tilt', '=1.3.3'
-
 platforms :jruby do
   gem 'jruby-openssl'
   gem 'puma'

http://git-wip-us.apache.org/repos/asf/deltacloud/blob/e961458a/server/deltacloud-core.gemspec
----------------------------------------------------------------------
diff --git a/server/deltacloud-core.gemspec b/server/deltacloud-core.gemspec
index 4f80dea..ce035c5 100644
--- a/server/deltacloud-core.gemspec
+++ b/server/deltacloud-core.gemspec
@@ -69,7 +69,6 @@ Gem::Specification.new do |s|
   s.has_rdoc = 'false'
   s.add_dependency('rake', '>= 0.8.7')
   s.add_dependency('haml', '>= 2.2.17')
-  s.add_dependency('sinatra', '>= 1.3.0')
   s.add_dependency('sinatra-rabbit', '>= 1.1.6')
   s.add_dependency('rack', '>= 1.0.0')
   s.add_dependency('rack-accept')
@@ -77,9 +76,15 @@ Gem::Specification.new do |s|
   s.add_dependency('net-ssh', '>= 2.0.0')
   s.add_dependency('nokogiri', '>= 1.4.3')
   s.add_dependency('require_relative') if RUBY_VERSION < '1.9'
-
   s.add_dependency('sequel', '<= 3.42.0')
 
+  # FIXME: These dependencies are locked due to bugs that
+  #        we will not address in this release.
+  #
+  s.add_dependency('tilt', '<=1.3.3')
+  s.add_dependency('sinatra', '<=1.3.5')
+
+
   if RUBY_PLATFORM == 'java'
     s.add_dependency('jdbc-sqlite3')
   else


Mime
View raw message