deltacloud-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mfoj...@apache.org
Subject git commit: Core: Added SQLite3.load_driver for JDBC (jRuby)
Date Tue, 19 Feb 2013 11:08:20 GMT
Updated Branches:
  refs/heads/master a1882b7c5 -> 4dee8b778


Core: Added SQLite3.load_driver for JDBC (jRuby)


Project: http://git-wip-us.apache.org/repos/asf/deltacloud/repo
Commit: http://git-wip-us.apache.org/repos/asf/deltacloud/commit/4dee8b77
Tree: http://git-wip-us.apache.org/repos/asf/deltacloud/tree/4dee8b77
Diff: http://git-wip-us.apache.org/repos/asf/deltacloud/diff/4dee8b77

Branch: refs/heads/master
Commit: 4dee8b778eb8775db4dde9195ad84e4e68982594
Parents: a1882b7
Author: Michal Fojtik <mfojtik@redhat.com>
Authored: Tue Feb 19 12:07:49 2013 +0100
Committer: Michal fojtik <mfojtik@redhat.com>
Committed: Tue Feb 19 12:07:49 2013 +0100

----------------------------------------------------------------------
 server/bin/deltacloud-db-upgrade |    7 ++++++-
 1 files changed, 6 insertions(+), 1 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/deltacloud/blob/4dee8b77/server/bin/deltacloud-db-upgrade
----------------------------------------------------------------------
diff --git a/server/bin/deltacloud-db-upgrade b/server/bin/deltacloud-db-upgrade
index f87af84..290dc77 100755
--- a/server/bin/deltacloud-db-upgrade
+++ b/server/bin/deltacloud-db-upgrade
@@ -17,7 +17,12 @@
 require 'rubygems'
 require 'require_relative' if RUBY_VERSION < '1.9'
 
-require 'jdbc/sqlite3' if RUBY_PLATFORM == 'java'
+# Fix loading of SQLite3 driver in JDBC
+#
+if RUBY_PLATFORM == 'java'
+  require 'jdbc/sqlite3'
+  Jdbc::SQLite3.load_driver
+end
 
 # Do not exit
 ENV['DB_UPGRADE'] = 'true'


Mime
View raw message