deltacloud-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mar...@apache.org
Subject [2/2] git commit: SITE - add output for 'require_relative' note on install
Date Wed, 21 Nov 2012 10:23:51 GMT
SITE - add output for 'require_relative' note on install


Project: http://git-wip-us.apache.org/repos/asf/deltacloud/repo
Commit: http://git-wip-us.apache.org/repos/asf/deltacloud/commit/495098ff
Tree: http://git-wip-us.apache.org/repos/asf/deltacloud/tree/495098ff
Diff: http://git-wip-us.apache.org/repos/asf/deltacloud/diff/495098ff

Branch: refs/heads/master
Commit: 495098ff5f882c802425951969bd3aeced8a2911
Parents: dad2fb4
Author: marios <marios@redhat.com>
Authored: Wed Nov 21 09:32:35 2012 +0200
Committer: marios <marios@redhat.com>
Committed: Wed Nov 21 12:21:06 2012 +0200

----------------------------------------------------------------------
 site/output/install-deltacloud.html |    8 ++++++++
 1 files changed, 8 insertions(+), 0 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/deltacloud/blob/495098ff/site/output/install-deltacloud.html
----------------------------------------------------------------------
diff --git a/site/output/install-deltacloud.html b/site/output/install-deltacloud.html
index 3f953fd..df936f1 100644
--- a/site/output/install-deltacloud.html
+++ b/site/output/install-deltacloud.html
@@ -222,6 +222,14 @@ the Wiki</a>. Note that they require using homebrew.</p>
 
 <p><strong>And thats it!</strong> The gem install command will automatically
fetch and install all other gems that the Deltacloud server needs. As an alternative you can
get the latest releases of Deltacloud from the <a href="http://www.apache.org/dist/deltacloud/">Apache
website</a>.</p>
 
+<p><span class="label">Note:</span> When installing and running Deltacloud
on platforms with Ruby versions 1.8.x, the 'require_relative' gem needs to be installed. This
gem should be automatically installed with the deltacloud-core gem however, if this does not
occur, the follow error will be thrown when starting Deltacloud: </p>
+
+<pre>/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require':
no such file to load -- require_relative (LoadError)</pre>
+
+<p>The fix is to explicitly install the 'require_relative' gem: </p>
+
+<pre>$ sudo gem install require_relative</pre>
+
 <p><a class="btn btn-inverse btn-large" style="float: right" href="run-deltacloud-server.html">Run
Deltacloud</a></p>
 
 <p><br></p>


Mime
View raw message