deltacloud-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lut...@apache.org
Subject [15/15] git commit: Gogrid tests: change requires to allow running tests with just ruby
Date Tue, 28 Aug 2012 00:16:55 GMT
Gogrid tests: change requires to allow running tests with just ruby


Project: http://git-wip-us.apache.org/repos/asf/deltacloud/repo
Commit: http://git-wip-us.apache.org/repos/asf/deltacloud/commit/467d54f9
Tree: http://git-wip-us.apache.org/repos/asf/deltacloud/tree/467d54f9
Diff: http://git-wip-us.apache.org/repos/asf/deltacloud/diff/467d54f9

Branch: refs/heads/master
Commit: 467d54f941dca875809052a4ea34db2d2f10eb0f
Parents: b6193c5
Author: David Lutterkort <lutter@redhat.com>
Authored: Fri Aug 24 11:11:38 2012 -0700
Committer: David Lutterkort <lutter@redhat.com>
Committed: Fri Aug 24 11:11:38 2012 -0700

----------------------------------------------------------------------
 .../tests/drivers/gogrid/hardware_profiles_test.rb |    7 +++----
 server/tests/drivers/gogrid/images_test.rb         |    7 +++----
 server/tests/drivers/gogrid/instances_test.rb      |    7 +++----
 server/tests/drivers/gogrid/realms_test.rb         |    7 +++----
 4 files changed, 12 insertions(+), 16 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/deltacloud/blob/467d54f9/server/tests/drivers/gogrid/hardware_profiles_test.rb
----------------------------------------------------------------------
diff --git a/server/tests/drivers/gogrid/hardware_profiles_test.rb b/server/tests/drivers/gogrid/hardware_profiles_test.rb
index def1232..2fbc0b3 100644
--- a/server/tests/drivers/gogrid/hardware_profiles_test.rb
+++ b/server/tests/drivers/gogrid/hardware_profiles_test.rb
@@ -1,7 +1,7 @@
-require 'minitest/autorun'
+require 'rubygems'
+require 'require_relative' if RUBY_VERSION < '1.9'
 
-require_relative File.join('..', '..', '..', 'lib', 'deltacloud', 'api.rb')
-require_relative 'common.rb'
+require_relative 'common'
 
 describe 'GoGrid Hardware Profiles' do
 
@@ -50,4 +50,3 @@ describe 'GoGrid Hardware Profiles' do
   end
 
 end
-

http://git-wip-us.apache.org/repos/asf/deltacloud/blob/467d54f9/server/tests/drivers/gogrid/images_test.rb
----------------------------------------------------------------------
diff --git a/server/tests/drivers/gogrid/images_test.rb b/server/tests/drivers/gogrid/images_test.rb
index 2c32baf..a726595 100644
--- a/server/tests/drivers/gogrid/images_test.rb
+++ b/server/tests/drivers/gogrid/images_test.rb
@@ -1,7 +1,7 @@
-require 'minitest/autorun'
+require 'rubygems'
+require 'require_relative' if RUBY_VERSION < '1.9'
 
-require_relative File.join('..', '..', '..', 'lib', 'deltacloud', 'api.rb')
-require_relative 'common.rb'
+require_relative 'common'
 
 describe 'GoGridDriver Images' do
 
@@ -43,4 +43,3 @@ describe 'GoGridDriver Images' do
   end
 
 end
-

http://git-wip-us.apache.org/repos/asf/deltacloud/blob/467d54f9/server/tests/drivers/gogrid/instances_test.rb
----------------------------------------------------------------------
diff --git a/server/tests/drivers/gogrid/instances_test.rb b/server/tests/drivers/gogrid/instances_test.rb
index 136272b..a4dbd66 100644
--- a/server/tests/drivers/gogrid/instances_test.rb
+++ b/server/tests/drivers/gogrid/instances_test.rb
@@ -1,8 +1,7 @@
+require 'rubygems'
+require 'require_relative' if RUBY_VERSION < '1.9'
 
-require 'minitest/autorun'
-
-require_relative File.join('..', '..', '..', 'lib', 'deltacloud', 'api.rb')
-require_relative 'common.rb'
+require_relative 'common'
 
 describe 'GoGridDriver Instances' do
 

http://git-wip-us.apache.org/repos/asf/deltacloud/blob/467d54f9/server/tests/drivers/gogrid/realms_test.rb
----------------------------------------------------------------------
diff --git a/server/tests/drivers/gogrid/realms_test.rb b/server/tests/drivers/gogrid/realms_test.rb
index 6b4d904..7e4bbd3 100644
--- a/server/tests/drivers/gogrid/realms_test.rb
+++ b/server/tests/drivers/gogrid/realms_test.rb
@@ -1,7 +1,7 @@
-require 'minitest/autorun'
+require 'rubygems'
+require 'require_relative' if RUBY_VERSION < '1.9'
 
-require_relative File.join('..', '..', '..', 'lib', 'deltacloud', 'api.rb')
-require_relative 'common.rb'
+require_relative 'common'
 
 describe 'GoGridDriver Realms' do
 
@@ -44,4 +44,3 @@ describe 'GoGridDriver Realms' do
   end
 
 end
-


Mime
View raw message