db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angela Day <akc...@yahoo.com>
Subject Re: [Torque] Using Torque again
Date Tue, 10 Nov 2009 21:23:10 GMT
That was it.  The previous developer has some custom vm files out there that are choking. 
I replaced them with the files from the templates jar and it builds successfully.  Now the
only problem is figuring out what he did that was custom and integrating it into the new environment.
 He had it doing flips and creating custom form classes and om classes with extra methods.
 I have my work cut out for me.

Thanks for all of your help,

 
Angela Day
National Autism Association of Central Texas

http://www.naacentraltexas.org
formally FEAT Austin





________________________________
From: Thomas Vandahl <tv@apache.org>
To: torque-user@db.apache.org
Sent: Tue, November 10, 2009 2:51:43 PM
Subject: Re: [Torque] Using Torque again

On 10.11.09 20:52, Angela Day wrote:
> Here is my default.properties file.  my build.properties file is empty.  The problem
seems to be referencing from the vm files that generate the om files.  Has there been an update
to those vm files for 3.3?  There is very little documentation on velocity that I can gleen
anything from.

Absolutely. Actually, there is not much left from the original template
files from 3.2 to 3.3, let alone 1.0.

> project = cdb
> database = oracle
> targetPackage = org.apache.torque
> 
> torque.project = ${project}
> torque.database = ${database}
> torque.targetPackage = ${targetPackage}
> torque.runOnlyOnSchemaChange = false

The file looks mostly OK to me.

> outputDirectory = src
> schemaDirectory = conf
> templatePath = templates
> useClasspath = true
> 
> torque.output.dir = ${torque.home}/${outputDirectory}
> torque.schema.dir = ${torque.home}/${schemaDirectory}
> torque.templatePath = ${templatePath}
> torque.useClasspath = ${useClasspath}

I'd probably put the templatePath out of the way. You should be fine
with the current templates from the JAR.

> torque.saveJavaName = ${sameJavaName}

This looks like a typo. But it could most probably not cause the
problems you are experiencing.

> overloadKeySetters = true
Dunno this one.

> useClasspath = false
[...]
> torque.useClasspath = ${useClasspath}

This is a dangerous duplication. You set this before further up and
overwrite it here with false. This might be your sole problem.

> # -------------------------------------------------------------------
> #
> #  C O N T R O L   T E M P L A T E S
> #
> # -------------------------------------------------------------------
> 
> SQLControlTemplate = sql/base/Control.vm
> OMControlTemplate = om/Control.vm
> idTableControlTemplate = sql/id-table/Control.vm
> DataDTDControlTemplate = data/Control.vm
> DataDumpControlTemplate = data/dump/Control.vm
> DataSQLControlTemplate = sql/load/Control.vm
> DocControlTemplate = doc/Control.vm
> 
> torque.template.sql = ${SQLControlTemplate}
> torque.template.om = ${OMControlTemplate}
> torque.template.idTable = ${idTableControlTemplate}
> torque.template.dataDtd = ${DataDTDControlTemplate}
> torque.template.dataDump = ${DataDumpControlTemplate}
> torque.template.dataSql = ${DataSQLControlTemplate}
> torque.template.doc = ${DocControlTemplate}
> torque.template.sqlDbInit = sql/db-init/Control.vm
> torque.template.ojb = ojb/repository/Control.vm
> torque.template.ojbModel = ojb/model/Control.vm

I don't think this is supported anymore.

Bye, Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message