db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angela Day <akc...@yahoo.com>
Subject Re: [Torque] Using Torque again
Date Mon, 09 Nov 2009 22:51:55 GMT
Ok, I see how it works.  templatePath is defined as templates in the default.properties file.
 There is a directory called src/templates.  I am assuming that it what it is pointing to.
 Do I need to update something in that directory maybe?

 
Angela Day
National Autism Association of Central Texas

http://www.naacentraltexas.org
formally FEAT Austin





________________________________
From: Angela Day <akcday@yahoo.com>
To: Apache Torque Users List <torque-user@db.apache.org>
Sent: Mon, November 9, 2009 4:47:47 PM
Subject: Re: [Torque] Using Torque again


Sheldon,
In reviewing that section of code 'torque.templatePath' is not defined.  It is not defined
in the template from the zip file, so I am not sure what the value should be.  I think that
is the line on which it is failing.
Would you know?
Thanks,

 
Angela Day
National Autism Association of Central Texas

http://www.naacentraltexas.org
formally FEAT Austin





________________________________
From: Sheldon Ross <sross@simmgene.com>
To: Apache Torque Users List <torque-user@db.apache.org>
Sent: Mon, November 9, 2009 4:28:24 PM
Subject: Re: [Torque] Using Torque again

Ok, ant uses xml in order to define tasks. These tasks are called targets. In my file the
target around lines 500-530 are the targets for building your OM objects, which I assume you're
trying to do.

In those targets are references to files and properties that the target needs to execute.

>From my xml.

   <torque-data-model
     contextProperties="${torque.contextProperties}"
     controlTemplate="${torque.template.dataDtd}"
     outputDirectory="${torque.output.dir}"
     outputFile="report.${torque.project}.datadtd.generation"
     templatePath="${torque.templatePath}"
     useClasspath="${torque.useClasspath}"
     xmlFile="${torque.schema.dir}/${torque.project}-schema.xml"
   />

The "${torque.contextProperties}" file must be defined and exist (and path be right) for this
to execute properly If it doesn't you will get errors such as you report.

Ross

Angela Day wrote:
> No, I just replaced the build-torque.xml file with the one from torque-3.3.zip and just
made a few little adjustments on the jar files in the classpath.  I updated all of my jar
files to be at least as high as the dependencies list from the torque website.  I updated
my xxx-schema.xml to point to the correct database_3_3.xml file.  Did I leave anything out?
> 
> Thanks,
> 
>  Angela Day
> National Autism Association of Central Texas
> 
> http://www.naacentraltexas.org
> formally FEAT Austin
> 
> 
> 
> 
> 
> ________________________________
> From: Sheldon Ross <sross@simmgene.com>
> To: Apache Torque Users List <torque-user@db.apache.org>
> Sent: Mon, November 9, 2009 3:51:30 PM
> Subject: Re: [Torque] Using Torque again
> 
> >From what I understand, in newer versions of torque you should really not be editing
much in the build-torque.xml itself.
> 
> At the top of your file, there should be something like this.
> 
> <property name="build.properties" value="build.properties"/>
> <property name="torque.contextProperties" value="${build.properties}"/>
> <property file="${torque.contextProperties}"/>
> 
> This specifies the properties file torque will use for configuration. I'm guessing you
either don't have these lines defined correctly, or the (in this example) "build.properties"
file doesn't exist.
> 
> 
> Ross
> 
> Angela Day wrote:
>  
>> Never mind.  I realized I was missing the torque-gen-templates-3.3.jar.  But I am
still getting the original error:
>> 
>> Exception thrown by 'properties.load'
>> 
>> I have updated all of my jar files and specified them in the build-torque.xml file.
 I have updated my (project)-build.xml file.  I am not getting any complaints about any of
these files.  Any Help would be appreciated.
>> 
>> Thanks,
>> 
>>  Angela Day
>> National Autism Association of Central Texas
>> 
>> http://www.naacentraltexas.org
>> formally FEAT Austin
>> 
>> 
>> 
>> 
>> 
>> ________________________________
>> From: Angela Day <akcday@yahoo.com>
>> To: Apache Torque Users List <torque-user@db.apache.org>
>> Sent: Mon, November 9, 2009 3:18:29 PM
>> Subject: Re: [Torque] Using Torque again
>> 
>> I have been updating the build-torque.xml file and am now getting:
>> 
>> C:\workspace\contract\build-torque.xml:96: taskdef class org.apache.torque.task.TorqueDataModelTask
cannot be found
>> I have warning decoration next to all of the taskdefs.  In what jar are these classes
found?
>> 
>> 
>> Thanks,
>> 
>> Angela Day
>> National Autism Association of Central Texas
>> 
>> http://www.naacentraltexas.org
>> formally FEAT Austin
>> 
>> 
>> 
>> 
>> 
>> ________________________________
>> From: Sheldon Ross <sross@simmgene.com>
>> To: Apache Torque Users List <torque-user@db.apache.org>
>> Sent: Mon, November 9, 2009 3:00:29 PM
>> Subject: Re: [Torque] Using Torque again
>> 
>> It would appear that there are significant differences in the build.properties file
(and/or build-torque.xml) from 1.0 to 3.3.
>> 
>> My suggestion is to redo your old 1.0 build.properties file and make sure it is of
the proper form for 3.3 and use xml from 3.3
>> 
>> Ross
>> 
>> Angela Day wrote:
>>      
>>> I am trying to upgrade from Torque 1.0 to 3.3.  I have replaced all of the jar
files and made sure my dependencies were covered.  It is an existing application that
>>> was working until I converted, so I know it is finding the project-schema.xml
file
>>> correctly.  This question is posted on the
>>> internet multiple times, with no solution.  If you can help me out, I
>>> would really appreciate it.
>>> 
>>> 
>>> Thanks,
>>> Angela
>>> 
>>> 
>>> BUILD FAILED
>>> C:\workspace\contract\build.xml:157: Following error occured while executing
thi
>>> s line
>>> C:\workspace\contract\build-torque.xml:503: Following error occured while execut
>>> ing this line
>>> C:\workspace\contract\build-torque.xml:531: Exception thrown by 'properties.load
>>> '. For more information consult the velocity log, or invoke ant with the -debug
>>> flag.
>>>         at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(Projec
>>> tHelper.java:537)
>>>         at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:385)
>>>         at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:269)
>>>         at org.apache.tools.ant.Task.perform(Task.java:364)
>>>         at org.apache.tools.ant.Target.execute(Target.java:301)
>>>         at org.apache.tools.ant.Target.performTasks(Target.java:328)
>>>         at org.apache.tools.ant.Project.executeTarget(Project.java:1215)
>>>         at org.apache.tools.ant.Project.executeTargets(Project.java:1063)
>>>         at org.apache.tools.ant.Main.runBuild(Main.java:632)
>>>         at org.apache.tools.ant.Main.startAnt(Main.java:183)
>>>         at org.apache.tools.ant.launch.Launcher.run(Launcher.java:197)
>>>         at org.apache.tools.ant.launch.Launcher.main(Launcher.java:56)
>>> Caused by: C:\workspace\contract\build-torque.xml:503: Following error occured
w
>>> hile executing this line
>>> C:\workspace\contract\build-torque.xml:531: Exception thrown by 'properties.load
>>> '. For more information consult the velocity log, or invoke ant with the -debug
>>> flag.
>>>         at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(Projec
>>> tHelper.java:537)
>>>         at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:385)
>>>         at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:107)
>>> 
>>>         at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:269)
>>>         at org.apache.tools.ant.Task.perform(Task.java:364)
>>>         at org.apache.tools.ant.Target.execute(Target.java:301)
>>>         at org.apache.tools.ant.Target.performTasks(Target.java:328)
>>>         at org.apache.tools.ant.Project.executeTarget(Project.java:1215)
>>>         at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:383)
>>>         ... 10 more
>>> Caused by: C:\workspace\contract\build-torque.xml:531: Exception thrown by 'prop
>>> erties.load'. For more information consult the velocity log, or invoke ant with
>>> the -debug flag.
>>>         at org.apache.velocity.texen.ant.TexenTask.execute(TexenTask.java:596)
>>>         at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:269)
>>>          
>> -- Sheldon Ross
>> Software Development
>> American Simmental Association
>> sross@simmgene.com
>> (406)587-4531 ext 102 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
>> For additional commands, e-mail: torque-user-help@db.apache.org
>>      
> 
>  

-- Sheldon Ross
Software Development
American Simmental Association
sross@simmgene.com
(406)587-4531 ext 102 

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message