db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <fisc...@seitenbau.net>
Subject RE: init question
Date Tue, 16 Sep 2008 19:52:45 GMT
 > I'm using torque 3.1.1 in combination with turbine. 
> ...
> I proceeded with the following code:
> 
>             String confFile = config.getServletContext().getRealPath(
>                         "WEB-INF/conf/Torque.properties");
>             PropertiesConfiguration torqueConf =
>                   new PropertiesConfiguration();
>             torqueConf.load(confFile);
> 
>             Torque.shutdown();
> 
>             Torque.init(torqueConf);
> 
> ...
> After diving a bit into the Torque source I also added AnuncioPeer.
> getMapBuilder(AnuncioMapBuilder.CLASS_NAME) after init() as it seems it
> cannot get a table mapping from the table map. This doesn't resolve
> anything, though.
> 
> Am I doing something wrong here?
> I tried to see if I could upgrade to Torque 3.3, but Turbine is 
complaining
> in some ways.

Torque.shutdown did not work correctly in earlier versions of Torque; it 
messed up the Table/column maps. This is fixed now (I do not remember when 
exactly, please check the change logs).
I see two options for you
- backport the fix and buld Torque 3.1.1 yourself
- Use Torque 3.3 (maybe using a newer Turbine ? I have no idea, whether or 
how this works, I never worked with Turbine). Maybe someone experienced 
with Turbine on this list can give advice on this.

    Thomas
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message