db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Monroe" <Greg.Mon...@DukeCE.com>
Subject RE: Does derby support still work?
Date Mon, 25 Aug 2008 13:46:34 GMT
FWIW - I ran the V3.3RC3 Test project (same as release) against 
Derby 10.3.2.1 (both embedded and network server versions).  
This checks a LOT of standard functionality, including the 
table creation and data type mappings.

In the table creation side of things, there were no issues in 
creating the test tables (which include every Torque/JDBC 
supported data type.  There were some issues relating to 
Torque/Derby not being able to drop some tables because they 
contained circular foreign key references (part of what the 
test suite check that Torque handles).  This was handled 
manually in running the tests by making sure the DB was 
recreated from scratch each run.

The only functional test that failed was related to Derby not 
allowing expressions in an order by clause where grouping or 
distinct is used. E.g. ORDER BY UPPER(x.y) where x.y is in the
group fails because Derby does not consider UPPER(x.y) are 
part of the group.

This caused the testJoinOrderDistinct test case to fail... but 
everything else worked.

Here's the e-mail outlining the details:

http://mail-archives.apache.org/mod_mbox/db-torque-dev/200801.mbox/%3C8F
5843B903F59D4C8C6806BB49A39119051FC792@dukece-mail3.dukece.com%3E

> -----Original Message-----
> From: Graham Leggett [mailto:minfrin@sharp.fm]
> Sent: Monday, August 25, 2008 6:15 AM
> To: Apache Torque Users List
> Subject: Re: Does derby support still work?
> 
> Thomas Vandahl wrote:
> 
> > Graham Leggett wrote:
> >> ij> CREATE TABLE active ( active_id INTEGER NOT NULL, serial
VARCHAR
> NOT
> >> NULL, name VARCHAR NOT NULL, description VARCHAR NOT NULL,
> signature_id
> >> INTEGER NOT NULL, PRIMARY KEY(active_id), UNIQUE (serial));
> >> ERROR 42X01: Syntax error: Encountered "NOT" at line 1, column 66.
> >
> > I'm not exactly a Derby expert but in this case "serial" seems to be
> > responsible.
> 
> Column 66 and the error message both point at the word "NOT", rather
> than the word serial.
> 
> Some further digging over the weekend shows that Derby may not support
> the VARCHAR type properly (it seems to need to be VARCHAR(limit), not
> VARCHAR).
> 
> Is it Torque's responsibility to decide on the VARCHAR type, or is the
> choice of type left to the end user?
> 
> Regards,
> Graham
> --
DukeCE Privacy Statement:
Please be advised that this e-mail and any files transmitted with
it are confidential communication or may otherwise be privileged or
confidential and are intended solely for the individual or entity
to whom they are addressed. If you are not the intended recipient
you may not rely on the contents of this email or any attachments,
and we ask that you please not read, copy or retransmit this
communication, but reply to the sender and destroy the email, its
contents, and all copies thereof immediately. Any unauthorized
dissemination, distribution or copying of this communication is
strictly prohibited.

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message