db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shinkan <shin...@gmail.com>
Subject Log4J + Torque ... gonna drive me mad.
Date Wed, 30 Jul 2008 14:51:24 GMT
Hi everyone !

I'm trying to make Torque logging working through LOG4J, as it's apparently
the only reliable solution (I would have used the native Java Logger
interface :'( ).
I've tried many many many Google's answers requesting about "torque
logging", "torque log4j", "log4j" and more, and I still fail.

I now have this configuration .properties section, which is embedded in the
Torque.properties (which is by the way correctly loaded by Torque.init(...))

log4j.category.default = ALL, default
log4j.appender.default = org.apache.log4j.RollingFileAppender
log4j.appender.default.file = log/data.log
log4j.appender.default.layout = org.apache.log4j.PatternLayout
log4j.appender.default.layout.conversionPattern = %d [%t] %-5p %c - %m%n
log4j.appender.default.maxBackupIndex = 5
log4j.appender.default.maxFileSize = 5MB
log4j.appender.default.append = true

Is Torque supposed to init LOG4J at Torque.init( filePath ) phase ?
How could I proceed ?
I always get this message at app's startup :
log4j:WARN No appenders could be found for logger
log4j:WARN Please initialize the log4j system properly.
Thus, I've got absolutely no log ...

Please, help :'(

Many thanks in advance.

Some people, when confronted with a problem, think "I know, I'll use XML".
Now they have two problems. -- Jamie Zawinski / James Robertson

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message