db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen B. Mehegan" <omehe...@hi5.com>
Subject No DataSourceFactory configured
Date Thu, 07 Feb 2008 01:50:45 GMT
Hi, I've seen this question asked many times in the mailing list 
archives, but so far I can't figure out a solution to the problem in my 
case. I have a unit test that is using Easymock to create mock database 
objects to test against. When I run the test, it always fails with this 
error:

java.lang.NullPointerException: There was no DataSourceFactory 
configured for the connection recoverable

But my Torque.properties _does_ include a datasource called 'recoverable:'

torque.dsfactory.recoverable.factory=com.friend.db.RecoverableDataSourceFactory
torque.dsfactory.recoverable.pool.maxActive=1
torque.dsfactory.recoverable.pool.maxIdle=1
torque.dsfactory.recoverable.pool.maxWait=1000
torque.dsfactory.recoverable.pool.testOnBorrow=false
torque.dsfactory.recoverable.pool.validationQuery=SELECT 1
torque.dsfactory.recoverable.connection.driver=com.mockrunner.mock.jdbc.MockDriver
torque.dsfactory.recoverable.connection.url = java://foo
torque.dsfactory.recoverable.connection.user = user
torque.dsfactory.recoverable.connection.password = foo

This entry is similar to others in the torque.properties, so I don't 
think the syntax is incorrect. What else could I be doing wrong?

-- 
Owen B. Mehegan
Database Framework QA Guy
"He is a dangerous mixture of sophistication and recklessness which
makes one anxious about his influence on other boys."

omehegan@hi5.com
YIM: omehegan
AIM: ottomaticjack
GTalk: omehegan@gmail.com

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message