db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Tomlinson" <wstom...@gmail.com>
Subject Is SQL Server 2005 supported in Torque?
Date Fri, 19 Jan 2007 19:54:10 GMT
I've read the faqs and docs, but I can't find a page where the 2005
version of SQL server is explicitly mentioned.

Short question: is SQL Server 2005 supported, and if so, what driver do I use?

Long details:

We have an older application using an older version of Torque and the
2000 version of SQL Server and using an older version of the SQL
Server JDBC driver from Microsoft. For various reasons we want to
switch to 2005.

I changed the connection url to the new database server (with 2005)
and I got this error which, to be honest, doesn't mean much to me:

FATAL ERROR: Problem connecting with database.([Microsoft][SQLServer JDBC Driver
][SQLServer]The incoming tabular data stream (TDS) remote procedure call (RPC) p
rotocol stream is incorrect. Parameter 1 (""): Data type 0x38 is unknown.)

So it's either our application, torque, or the quite old jdbc driver.

On the assumption that it is the jdbc driver, I downloaded the latest
SQL server jdbc driver from Microsoft and tried to run that. But I got
this error:

FATAL ERROR: Problem connecting with database.(Unknown JDBC driver: com.microsof
t.sqlserver.jdbc.SQLServerDriver: Check your configuration file)

Which I understand to mean that the driver isn't one that Torque
supports (Microsoft changed the package for the driver from the older
driver).

I checked the source code for DBFactory, and the trunk HEAD version
doesn't have this driver either. So am I correct that even the latest
version of Torque doesn't support the latest MS jdbc drivers?

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message