db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kintzel Levente" <kintzel.leve...@codespring.ro>
Subject RE: Postgres How to
Date Mon, 20 Mar 2006 08:29:08 GMT
Hi!

The problem is related to BLOB fields, only. Such a field is in the
TURBINE_USER table, and when the application saves a user the exception
occurs.
The problem is exactly what is described here:

http://db.apache.org/torque/releases/torque-3.2/docs-all-components/database
-howtos/postgres-howto.html

but the given patch is not for the latest driver because the patch crashes.
And the latest driver compiled doesn't fix the problem.

Thanks,
      Levi

P.S. the "blabla" is only an example string, usually appears some strange
characters.

-----Original Message-----
From: Jonathan Puvis [mailto:jon@reeltwo.com] 
Sent: Sunday, March 19, 2006 10:13 PM
To: Apache Torque Users List
Subject: Re: Postgres How to

On Sat, March 18, 2006 2:04 am, Kintzel Levente said:
> I'm using Torque 3.0.2. and Postgre SQL 7.48. The security part of my
> application is based on TurbineSecurity Service.
>
> But from time to time I receive some exception:
>
> com.workingdogs.village.DataSetException: Bad conversion:
> java.lang.NumberFormatException: For input string: blabla
>
> The same error occurs if I want to save an user.
>
> I read the Postgres How-To doc. I downloaded the latest jdbc driver source
> from CVS, I tried to run the patch. But it fails, because the content is
> different from what the patch expected. And with the new compiled driver,
> the problem still appears.
>
> Has anybody a correct version (patched) driver for this problem. Can
> somebody sent it to me. Or there are other solutions?
>
> If nobody has an idea I must migrate the database to mysql.

If the string it is having trouble with is "NaN" or "Infinity" then i have
a patch to Village to solve that (it makes NaN insert NULL in the database
and retriving NULL gives NaN instead of 0).  If it really is "blabla",
then perhaps you have one of the fields in project-schema.xml marked as a
string when it really is a integer in the database?

PostgreSQL does support NaN in the database, but it must be sent as 'NaN'
instead of NaN, which is what the JDBC driver sends it as (as it just does
.toString() on the value).  I have reported this bug to the PostgreSQL
mailing list, but it has yet to be fixed.

Neither MySQL or Microsoft SQl Server support NaN properly via JDBC
either, hence my patching Village to work around the problem.


Regards,

       Jon




---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message