db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <fisc...@seitenbau.net>
Subject RE: SQL generated schema
Date Mon, 14 Nov 2005 09:30:57 GMT




Hi,

As you did not provide details of the sql errors, just a wild guess:
Some template sets for databases do not allow forward declarations on
foreign key. So you have to make sure that the referenced table is before
the referencing table in the schema.xml

If this is not the cause of the error, it would really help to know the
Torque version you use and the message of the sql error when the tables are
created.

     Thomas

Jakub Piechnik <piechutm@wp.pl> schrieb am 12.11.2005 23:54:58:

> Hello
>
> I've created scham.xml file - and invoked "maven torque" command - I saw
> BUILD SUCCESSFUL, so I thought that everything'd gone oki. But when I
> tried to execute sql scripts genereted by torque I've got full of errors
> - especially when it comes to the table name - and finally there're 9
> out of 12 tables created in my database. Has anyone had such bug before
> - if so - how to solve it?
>
> Greetings
> Jakub Piechnik
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-user-help@db.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message