db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From econroy <econ...@ECONROY.NET>
Subject Read only mode error using HSQLDB
Date Mon, 07 Nov 2005 21:12:54 GMT
Hi all,
I am using HSQLDB for a database that is being stored on a cdrom.
I am using Torque 3.1.1 hsqldb 8.0. When I run the webapp where inside 
the database properties list readonly=true
I get the error : ERROR org.apache.torque.util.LargeSelect - 
org.apache.torque.TorqueException: java.sql.SQLException: The database 
is in read only mode.
If I run the database in readonly=false the webapp runs fine. I can 
connect to the database in readonly mode from DatabaseManager contained 
in HSQLDB. I have a feeling that connecting to the database in Torque 
still tries to lock the database and can't because it is readonly..
.

Thanks,
 Ed Conroy


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message