db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <tfisc...@apache.org>
Subject Re: Strange Error with 3.2rc-2 and 3.2rc-3
Date Tue, 22 Nov 2005 21:27:58 GMT
Yo do not have to run the test project to create a test case. Just create 
a litte schema.xml, and a test class which uses the objects from the 
schema to reproduce the error.

With regard to the test project: The goal "build" is defined in 
profile/base/maven.xml. As mysql/project.xml extends ../base/project.xml, 
also the maven.xml should be inherited from there.
What is a bit strange is that the foal "build" should not be needed to 
execute the default goal "torque-test:run"

Can you please make sure that
- you have not overwritten the extension to ../base/project.xml in 
mysql/project.xml
- you do use maven 1.0.2
- you invoke the maven command out of the test/test-project 
directory

If all of this is the case, can you please post your 
changed mysql/project.xml and the output of
maven --debug -Dmaven.test.profile=mysql
to the users List ?

    Thomas


On Mon, 21 Nov 2005, Youngho Cho wrote:

> Hello Thomas,
>
> I am tring to make some test cases to duplicate the problem.
> But I couldn't run the test.
>
> I downloaded the trunks from the svn repository.
> and modified the project.xml file paths as recommended in test project page.
>
> I finally got the following message.
>
> [youngho@test mysql]$ maven  -Dmaven.test.profile=mysql
> __  __
> |  \/  |__ _Apache__ ___
> | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> |_|  |_\__,_|\_/\___|_||_|  v. 1.0.2
>
> BUILD FAILED
> Goal "build" does not exist in this project.
> Total time: 13 seconds
> Finished at: Mon Nov 21 08:08:12 KST 2005
>
>
> How do I run the test ?
>
> Thanks,
>
> Youngho
>
> ----- Original Message -----
> From: "Thomas Fischer" <fischer@seitenbau.net>
> To: "Apache Torque Users List" <torque-user@db.apache.org>
> Sent: Wednesday, November 16, 2005 6:16 PM
> Subject: RE: Strange Error with 3.2rc-2 and 3.2rc-3
>
>
>>
>>
>>
>>
>> The issue seems to be that although only one row should be created by an
>> insert, more than one rows were created. This is not a known issue. To look
>> into this, more information is needed. Can you produce a test case which
>> reproduces the error and send it in ?
>>
>>       Thomas
>>
>> "Youngho Cho" <youngho@nannet.co.kr> schrieb am 16.11.2005 00:39:45:
>>
>>> Hello,
>>>
>>> I updated torque to 3.2rc-2 from 3.1 recently and got some strange error
>>> frequently when heavily insert mode. ( continuesly insert over few
>>> hundread object )
>>>
>>> please refer to the error message.
>>> Caused by: java.sql.SQLException: There were 197 rows inserted with
>>> this records key value.
>>>         at com.workingdogs.village.Record.saveWithInsert(Record.java:426)
>>>         at com.workingdogs.village.Record.save(Record.java:220)
>>>         at com.workingdogs.village.Record.save(Record.java:190)
>>>         at org.apache.torque.util.BasePeer.
>>> insertOrUpdateRecord(BasePeer.java:622)
>>>         ... 75 more
>>>
>>> It is happened windows and linux box both with MySQL4.1 and java 1.4.
>>> The DB and application is in same machine.
>>> and It was not happened torque-3.1.
>>>
>>> I don't know how I can solve it.
>>> Is it know issue ?
>>>
>>> Thanks.
>>>
>>> Youngho
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
>> For additional commands, e-mail: torque-user-help@db.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message