db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hilco Wijbenga <hilco.wijbe...@elasticpath.com>
Subject torque-data-sql - Log4j error
Date Wed, 09 Nov 2005 23:19:17 GMT
I'm seeing lots of log4j errors while running <torque-data-sql>. It's
completely repeatable but I'm not entirely clear as to why it's
happening.

I'm not sure this is a Torque problem (it could be an Ant thing). The
problem is benign in the sense that Torque does it's work but there are
lots and lots of error messages (probably an error message per line in
my XML file).

I have a number of targets in my build.xml that each call one of
<torque-data-model>, <torque-sql>, and <torque-data-sql> tasks.
Something like

<target name="a"><torque-data-model/></target>
<target name="b"><torque-sql/></target>
<target name="c"><torque-data-sql/></target>
<target name="d"><torque-data-sql/></target>

Targets 'a' and 'b' always run without problems. Targets 'c' and 'd' run
without problem if run separately. If I run targets 'a', 'b', 'c', and
'd' in the same build then target 'c' runs fine but target 'd' displays

d:
[torque-data-sql] Using contextProperties
file: /home/hilco/workspace/ep5/project.config
[torque-data-sql] src/main/db/templates
[torque-data-sql] Using classpath
[torque-data-sql] Generating to
file /home/hilco/workspace/ep5/target/postgresql/ep-ll.sql
[torque-data-sql] Nov 9, 2005 3:09:16 PM
org.apache.torque.engine.database.transform.XmlToAppData parseFile
[torque-data-sql] INFO: Parsing file: 'ep-schema.xml'
[torque-data-sql] Nov 9, 2005 3:09:16 PM
org.apache.torque.engine.database.transform.DTDResolver resolveEntity
[torque-data-sql] INFO: Resolver: used database.dtd from
'org.apache.torque.engine.database.transform' package
[torque-data-sql] Nov 9, 2005 3:09:16 PM
org.apache.torque.engine.database.transform.XmlToData resolveEntity
[torque-data-sql] INFO: Resolver:
used /home/hilco/workspace/ep5/src/main/db/ep-data.dtd
[torque-data-sql] log4j:ERROR Attempted to append to closed appender
named [null].

This last line is repeated hundreds of times. Again, the end result is
fine but the many hundreds of log4j errors are kind of distracting. :-)

All of this is 100% repeatable.

I can't find the offending log line (maybe it's in the Texen task?).
Changing the log4j.properties (in torque-gen-3.2-rc3-dev.jar) to include
%L does not change the output.

I'm at a loss here. Any ideas?

Thanks,
Hilco


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message