db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl von Randow" <k...@cactuslab.com>
Subject Deleting an object containing a Timestamp with 3.2 rc2 and Postgres + solution
Date Mon, 26 Sep 2005 05:10:04 GMT
Hi all,

I am experiencing a fault with Torque 3.2 rc2 when trying to delete an
object that contains a timestamp field using Postgresql. I've read in the
changes page
(http://db.apache.org/torque/runtime/changes-report.html#3_1_1-RC3) that
this was fixed in 3.1.1-RC3, however I am experiencing the problem.

I am using the postgres driver 7.4.216 jdbc3 and have tried with the latest
8.1dev-401 jdbc3 with the same result.

The problem appears to be the milliseconds component of the timestamp, eg.
2005-09-26 16:40:51.381

I have fixed the problem by modified /o/a/t/adapter/DBPostgres.java.

In DBPostgres.java the date format is missing the millisecond component.
According to the referenced spec
(http://www.postgresql.org/docs/7.3/static/datatype-datetime.html) a
timestamp is a date followed by a time, and time with millis is a time
format. So perhaps changing the date format in DBPostgres.java from:

"yyyy-MM-dd HH:mm:ss"

To

"yyyy-MM-dd HH:mm:ss.S"

Will be safe across the board and definitely fix the problem on my board.

Kind regards,
Karl


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message