db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <fisc...@seitenbau.net>
Subject RE: torque:datasql, oracle and ampersand
Date Tue, 03 May 2005 07:46:44 GMT




Roel,

Thanks for the hint.

>From the web sites you have quoted, this seems to be a problem of the
sqlplus console rather than the oracle db itself.
I guess that you execute the created scripts via sqlplus. Does this also
happen if ant executes the created script via jdbc ?

    Thomas

Roel van Dijk <rdvdijk@gmail.com> schrieb am 02.05.2005 09:26:36:

> I'm using Torque as part of Jetspeed, and it's working without any
troubles.
>
> Just a note though: I'm using the 'datasql' goal to create the .sql
> file from a project-data.xml file.The creation process works fine
> (Maven needed some extra memory for the few thousand entries..).  I'm
> using an Oracle database. However, the created insert-statements are
> not clean when there's a ampersand in the data. The created SQL looks
> something like:
>
> INSERT INTO MYTABLE (MYCOLUMN)
>    VALUES('this is & my data');
>
> However, you cannot insert an ampersand in Oracle this way. References:
>
> http://www.jlcomp.demon.co.uk/faq/litampersand.html
> http://www.orafaq.com/faqplus.htm#NOAT
>
> Not sure what the proper solution is for Torque, but I thought Torque
> developers should know.
>
> --
> Roel -- rdvdijk@gmail.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-user-help@db.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message