db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <fisc...@seitenbau.net>
Subject RE: Builds fine on Windows, Fails on Linux
Date Tue, 29 Mar 2005 07:17:07 GMT




Tom,

I do not think the operation system is a problem. I have no experience with
3.0.2, but from 3.1 on, the builds run also on linux.
Are you sure you do not have any absolute paths in your configuration ?

Perhaps it is best to start the installation from scratch on linux and copy
only the files you have modified, reviewing them as you copy them.

     Thomas

"Tom Lianza" <tlianza@hotmail.com> schrieb am 26.03.2005 22:39:42:

> Hi All,
>
> I have a torque project based on Torque 3.0.2.  Everything works fine
when I
> do a build on Windows.  However, when I copy all of my files down to my
> linux machine and try and run ant -f build-torque.xml I get the following

> error message:
>
> /home/tlianza/workspace/usoil/torque/build-torque.xml:122: The following
> error occurred while executing this line:
> /home/tlianza/workspace/usoil/torque/build-torque.xml:185: The following
> error occurred while executing this line:
> /home/tlianza/workspace/usoil/torque/build-torque.xml:216: Generation
> failed. For more information consult the velocity log, or invoke ant with

> the -debug flag.
>
> That error corresponds to the "templatePath" argument of the torque-sql
tag
> in my sql-template target.  Velocity.log doesn't show anything that I can

> see as useful:
>
> ----------------2005-03-26 16:31:59,618 - Starting Jakarta Velocity v1.3
> 2005-03-26 16:31:59,618 - RuntimeInstance initializing.
> 2005-03-26 16:31:59,618 - Default Properties File:
> org/apache/velocity/runtime/defaults/velocity.properties
> 2005-03-26 16:31:59,618 - Trying to use logger class
> org.apache.velocity.runtime.log.AvalonLogSystem
> 2005-03-26 16:31:59,618 - Couldn't find class
> org.apache.velocity.runtime.log.AvalonLogSystem or necessary supporting
> classes in classpath. Exception : java.lang.NoClassDefFoundError:
> org/apache/log/format/Formatter
> 2005-03-26 16:31:59,618 - Trying to use logger class
> org.apache.velocity.runtime.log.SimpleLog4JLogSystem
> 2005-03-26 16:31:59,618 - Using logger class
> org.apache.velocity.runtime.log.SimpleLog4JLogSystem
> 2005-03-26 16:31:59,621 - Default ResourceManager initializing. (class
> org.apache.velocity.runtime.resource.ResourceManagerImpl)
> 2005-03-26 16:31:59,624 - Resource Loader Instantiated:
> org.apache.velocity.runtime.resource.loader.FileResourceLoader
> 2005-03-26 16:31:59,625 - FileResourceLoader : initialization starting.
> 2005-03-26 16:31:59,625 - FileResourceLoader : adding path
> '/home/tlianza/workspace/usoil/torque/templates'
> 2005-03-26 16:31:59,625 - FileResourceLoader : initialization complete.
> 2005-03-26 16:31:59,629 - ResourceCache : initialized. (class
> org.apache.velocity.runtime.resource.ResourceCacheImpl)
> 2005-03-26 16:31:59,629 - Default ResourceManager initialization
complete.
> 2005-03-26 16:31:59,631 - Loaded System Directive:
> org.apache.velocity.runtime.directive.Literal
> 2005-03-26 16:31:59,632 - Loaded System Directive:
> org.apache.velocity.runtime.directive.Macro
> 2005-03-26 16:31:59,633 - Loaded System Directive:
> org.apache.velocity.runtime.directive.Parse
> 2005-03-26 16:31:59,635 - Loaded System Directive:
> org.apache.velocity.runtime.directive.Include
> 2005-03-26 16:31:59,637 - Loaded System Directive:
> org.apache.velocity.runtime.directive.Foreach
> 2005-03-26 16:31:59,733 - Created: 20 parsers.
> 2005-03-26 16:31:59,733 - Velocimacro : initialization starting.
> 2005-03-26 16:31:59,733 - Velocimacro : adding VMs from VM library
template
> : VM_global_library.vm
> 2005-03-26 16:31:59,736 - ResourceManager : unable to find resource
> 'VM_global_library.vm' in any resource loader.
> 2005-03-26 16:31:59,736 - Velocimacro : error using  VM library template
> VM_global_library.vm :
> org.apache.velocity.exception.ResourceNotFoundException: Unable to find
> resource 'VM_global_library.vm'
> 2005-03-26 16:31:59,736 - Velocimacro :  VM library template macro
> registration complete.
> 2005-03-26 16:31:59,736 - Velocimacro : allowInline = true : VMs can be
> defined inline in templates
> 2005-03-26 16:31:59,736 - Velocimacro : allowInlineToOverride = false :
VMs
> defined inline may NOT replace previous VM definitions
> 2005-03-26 16:31:59,736 - Velocimacro : allowInlineLocal = false : VMs
> defined inline will be  global in scope if allowed.
> 2005-03-26 16:31:59,736 - Velocimacro : messages on  : VM system will
output
> logging messages
> 2005-03-26 16:31:59,736 - Velocimacro : autoload off  : VM system will
not
> automatically reload global library macros
> 2005-03-26 16:31:59,736 - Velocimacro : initialization complete.
> 2005-03-26 16:31:59,736 - Velocity successfully started.
> -------------------------
>
> Any ideas?  This same set of files builds fine with Windows, so I'm
thinking
> it's either something environmental (classpath environment variable?) or
> os-dependent... I just don't see what that could be.
>
> Thanks!
> Tom
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-user-help@db.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message