db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From adam.s.allga...@exxonmobil.com
Subject Re: torque:jdbc isn't right
Date Thu, 24 Feb 2005 20:54:56 GMT
It sounds like your id-table logic is embedded into your app-schema.xml,
instead of broken out into a separate schema file.

Adam




                                                                                         
                                        
                      "Brandon"                                                          
                                        
                      <eff4eye@hotmail.com>          To:      "Apache Torque Users List"
<torque-user@db.apache.org>              
                                                     cc:                                 
                                        
                                                     Subject: torque:jdbc isn't right    
                                        
                      02/24/05 10:30 AM                                                  
                                        
                      Please respond to                                                  
                                        
                      "Apache Torque Users                                               
                                        
                      List"                                                              
                                        
                                                                                         
                                        
                                                                                         
                                        



I'm having a problem using the torque:jdbc call.  It doesn't seem to be
treating the database as using the native idMethod even though I defined
the
DB that way, and used Torque to create and populate the DB.  But it doesn't

seem to be pulling the very information that it put into the database.
Surprisingly enough it does create the XML files properly, and everything
seems to be working properly, but it creates a class called
BaseIdTablePeer.
The interesting thing is that it creates a duplicate name for a String in
the file.  Here's what the generated code looks like:

/** the default database name for this class */
public static final String DATABASE_NAME = "default";

/** the table name for this class */
public static final String TABLE_NAME = "id_table";

/**
 * @return the map builder for this peer
 * @throws TorqueException Any exceptions caught during processing will be
 *                rethrown wrapped into a TorqueException
 */
public static MapBuilder getMapBuilder()
      throws TorqueException
{
      return getMapBuilder(IdTableMapBuilder.CLASS_NAME);
}

/** the column name for the ID_TABLE_ID field */
public static final String ID_TABLE_ID;
/** the column name for the TABLE_NAME field */
public static final String TABLE_NAME;




Notice that the string TABLE_NAME is defined twice.  I am not sure why it
is
generating things like this.  It also indicates that it's using the
id_table
stuff rather than the native stuff I defined when I created the DB for the
idMethod.  Anyone have any thoughts?

-Brandon

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message