db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henning P. Schmiedehausen" <...@intermeta.de>
Subject Re: Torque using Tomcat
Date Mon, 27 Dec 2004 09:03:48 GMT
"M. Sean Gilligan" <Sean_Gilligan@catalla.com> writes:

>Hi Henning,

>Thanks again for your help.  (I got sidetracked for a few days.)

Hi, 

no prob.

>>>>I remember this from a dim and distant past. It was some serialization
>>>>issue. Can you please look into your catalina.out and maybe look into the
>>>>list archives?
>>
>>>Hi Henning.
>>
>>>Thanks for your response.
>>
>>>What do you mean by a "serialization issue"?
>>
>>Your container probably tries to save the existing session on a
>>restart (because reloading your webapp is nothing but a restart of
>>your application) and falls over its feets. When it comes up again,
>>its session information is incomplete and you get strange errors.

>What would Torque have to do with the Http session?  I don't understand the connection
here.

The container serializes the state of your application. Which means,
that it might serialize the state of the MapBuilders, connection
factories and so on. As I said, I remember this dimly so I wasn't sure
that this is the same issue.


>>
>>Try the following thing. I assume now, that you use Tomcat5:
>>
>>- open your tomcat/conf/server.xml file
>>
>>- look for the <Context> element for your application.
>>
>>- if you don't have one, you must create one. The result should look like
>>  this:
>>
>><Context path="/your-app-here" reloadable="true">
>>   <Manager className="org.apache.catalina.session.StandardManager"
>>            distributable="false" pathname="" />
>></Context>
>>
>>Important is the 'pathname=""'
>>
>>Stop Tomcat. Nuke the contents of the work/ and the temp/
>>directory. Start again. See if the problem vanishes. If yes, you have
>>a serialization issue with Torque.

>I did what you said and the problem did not go away.  To be clear: the problem is fixed
by a restart of Tomcat and only occurs when you reload the webapp after it has been loaded
once.  I followed your instructions (which included a restart of Tomcat) tried to login once
and it worked, the restarted the webapp and tried to login again and got the same stack trace.

Ok. So it does not seem to be this. At this point, a debugger might be
your best friend to find the root cause of this problem.

>Any further information and/or suggestions would be greatly appreciated.
>Thanks,

I have no immediate ideas; opening a bug report so this won't be
forgotten might be a good thing, though.

	Regards
		Henning


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message