db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <Fisc...@seitenbau.net>
Subject Re: Torque using Tomcat
Date Thu, 30 Dec 2004 08:28:02 GMT




> I really do want to use a QA'ed release for my alpha/beta/production
> release, so I also tried copying JndiDataSourceFactory.java into the
> 3.1.1 directory tree and am unable to do a build:
>
> java:compile:
>     [echo] Compiling to /Users/sean/netcvs/jakarta/db-torque-3-1-1-
> patched/target/classes
>     [javac] Compiling 69 source files to
> /Users/sean/netcvs/jakarta/db-torque-3-1-1-patched/target/classes
> /Users/sean/netcvs/jakarta/db-torque-3-1-1-
> patched/src/java/org/apache/torque/dsfactory/JndiDataSourceFactory.
> java:99: cannot resolve symbol
> symbol  : method initialize
(org.apache.commons.configuration.Configuration)
> location: class org.apache.torque.dsfactory.AbstractDataSourceFactory
>         super.initialize(configuration);
>              ^
> Note: Some input files use or override a deprecated API.
> Note: Recompile with -deprecation for details.
> 1 error
>
> Any suggestions on what to do with the 3.1.1 tree?

If you want to use JndiDataSourceFactory from the 3.1.1 tree, you also need
the AbstractDataSourceFactory class and probably the other
DataSourceFactories from the 3.1.1 tree. Maybe there are other dependencies
in there, but I do not know the code well enough to tell without trying. If
patching the 3.1.1 file with the change you found in the mail archives
works, this should be fine.

   Thomas


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message