db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From T E Schmitz <mail...@numerixtechnology.de>
Subject Re: where is build-torque.xml?
Date Wed, 11 Aug 2004 15:48:07 GMT


Nathaniel Reed wrote:

> Where is src/generator?

Sorry, I must've looked inside the src download of the generator. In the 
.zip file build-torque.xml is in the top level folder once extracted. I 
can't believe that the .tar file would be structured differently.

Never, mind I got confused, too, at the beginning, only I had missed the 
runtime download. ;-)



> 
> --- T E Schmitz <mailreg@numerixtechnology.de> wrote:
> 
> 
>>Hello Nate,
>>
>>If you downloaded the generator torque-gen-3.1.zip (
>>as opposed to 
>>torque-3.1.zip !!!!, which is the runtime), you will
>>find 
>>build-torque.xml in \torque-3.1\src\generator, which
>>is what you use for 
>>building your app with Ant.
>>
>>Regards,
>>Tarlika
>>
>>Nathaniel Reed wrote:
>>
>>
>>>I have tried both (also, I tried an older version,
>>>torque 3.0).  Unfortunately, I get the same build
>>>errors.  When I apply the workarounds I mentioned
>>
>>in
>>
>>>my last message, I am able to build the jar but
>>
>>there
>>
>>>is no build-torque.xml in either distribution.
>>>
>>>There is a reference to build-torque.xml in
>>
>>maven.xml.
>>
>>> Am I missing something?  Do I need maven to build
>>>this instead of ant?
>>>
>>>Thanks,
>>>Nate
>>>
>>>--- adam.s.allgaier@exxonmobil.com wrote:
>>>
>>>
>>>
>>>>Are you using the torque-31 distribution or the
>>>>torque-gen-31 distribution?
>>>>The *gen* version will have the additional
>>
>>libraries
>>
>>>>to build your Torque
>>>>application model.
>>>>
>>>>Adam
>>>>
>>>>
>>>>
>>>>                                                 
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                     Nathaniel Reed              
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                     <natereed@sbcglobal.n       
>>
>> 
>>
>>>>To:      torque-user@db.apache.org                
>>
>> 
>>
>>>>                             
>>>>                     et>                         
>>
>> 
>>
>>>>cc:                                               
>>
>> 
>>
>>>>                             
>>>>                                                 
>>
>> 
>>
>>>>Subject: where is build-torque.xml?               
>>
>> 
>>
>>>>                             
>>>>                                                 
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                     08/10/04 11:56 PM           
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                     Please respond to           
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                     "Apache Torque Users        
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                     List"                       
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                                                 
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>                                                 
>>
>> 
>>
>>>>                                                 
>>
>> 
>>
>>>>                             
>>>>
>>>>
>>>>
>>>>It's been a long time since I've used Torque (so
>>>>long
>>>>ago that it was part of Turbine).  I'm in the
>>>>process
>>>>of porting an old app that used a previous version
>>>>of
>>>>Torque but running into problems getting started.
>>>>
>>>>I have downloaded and attempted build Torque 3.1. 
>>>>Is
>>>>the build-torque.xml supposed to be included in
>>
>>the
>>
>>>>distribution?  There is no such file.
>>>>
>>>>Also, there are numerous errors in the build.xml
>>>>script.  I had to replace the paths
>>>>/home/martin/workspace... with the correct
>>
>>relative
>>
>>>>paths.  Also, it appears that there were some
>>>>problems
>>>>downloading other jar's:
>>>>
>>>>Getting:
>>
>>>http://www.ibiblio.org/maven/jdbc/jars/jdbc-2.0.jar
>>>
>>>>     [get] Error opening connection
>>>>java.io.IOException
>>>>     [get] Error opening connection
>>>>java.io.IOException
>>>>     [get] Error opening connection
>>>>java.io.IOException
>>>>
>>>>These don't seem to be fatal, though.
>>>>
>>>>Also, it fails because Junit is not found, even
>>>>though
>>>>the junit jar is in the target/lib directory and
>>>>included in the classpath:
>>>>
>>>>BUILD FAILED
>>>>/home/nate/torque-3.1/build.xml:73: Could not
>>
>>create
>>
>>>>task or type of type: junit.
>>>>
>>>>I commented out the test targets, and was able to
>>>>compile and create the torque jar, but these above
>>>>errors make me uneasy.  Also, I'm not sure how to
>>>>use
>>>>the jar file without the build-torque.xml script. 
>>>>Any
>>>>help is appreciated.
>>>>
>>>>Thanks,
>>>>Nate
>>>>
>>


-- 


Regards/Gruß,

Tarlika Elisabeth Schmitz

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message