db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ron piterman <ron.piter...@gmx.net>
Subject Re: IdGenerator is null
Date Tue, 13 Jul 2004 10:13:54 GMT
I don't know about the database name, but I added the two things you 
said and it works :)))
Thanx.
How come the ant task does not generate this correctly?
There are also other problems using my workflow: database -> schema 
(jdbc task) -> om
byte fields, for example, need a cast: (byte)0, which isn't there.
But I guess thats all only small crumbs...
Cheers,
Ron


Andras Balogh wrote:

> Hello,
>
>    Torque  doesn't need the schema at runtime, all the information  is 
> stored in the Map classes.
> Currently i think Torque is "confused" at your side  which method to 
> use to generate unique keys:
> IDBroker - this is implemented in Torque
> Native - this is implemented by the DB in your case MYSQL and 
> auto_increment fields.
> (i hope your are using auto_increment fields in DB??!)


Yes I am :)

>
> Andras.
>
>
> ron piterman wrote:
>
>> Does Torque needs my Schema to do IDs? Also after I generate the 
>> Object Model? because Currently it has no access to the schema file.
>> (I can hardly imagine this is happening, since in the properties or 
>> in the configuration method, there is no reference to the schema 
>> file, so, suppose torque needs it, how would it find it?)
>> Cheers, and thanx - I will try it now...
>> Ron
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-user-help@db.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message