db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saravana Kannan <skka...@engr.uky.edu>
Subject Re: Updates to Blobs/ Oracle
Date Wed, 05 May 2004 16:46:32 GMT
Hi,

> I'm updating a table with 2 Blob fields in an Oracle 9i databse (9.0.2.4
> I think) using the latest Oracle JDBC drivers (10g) which
> seem to work fine (most of the time).

Is this a sane thing to do? Using a 10g driver for a 9i database! Also is it 
advisable for a commercial project?

> 
> This seems to be happening deep within Torque - perhaps in the JDBC
> driver. I'll check this next.

It's the crazy Oracle JDBC driver. I tried the trial version of DataDirects JDBC 
driver and it works awesome! I tried up to 500KB and I have seens mails saying 
they tried till 9MB. The problem is that the Oracle JDBC driver doesn't stick to 
the standards.

> 
> has anyone seen this behaviour?? anyone know how to fix it??

For me writing a BLOB > 4000 (or maybe 2000) bytes gives me a "Connection 
Reset". I used the 9i JDBC. I downloaded the code for Village and I'm working on 
it. I found where the BLOB is saved and I added Oracle specific code. Worked 
yday till 5am and it still gives me some error "null"! Doesn't even say on which 
line! Will let u all know if I'm done with it!

~Sarav


-- 
There are 10 kinds of people in the world,
those who know binary and those who don't.


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message