db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cameron Hickey" <...@panoramatos.com>
Subject Generated OM classes have $clo instead of column names
Date Thu, 27 May 2004 14:14:10 GMT
I have been using torque 3.0 for the last year, and now that I am
starting a new project I decided to upgrade to the 3.1 split generation
tool.

After managing to get the JDBC task to properly generate a new schema
file from an existing database I need to use, I tried using the main ant
task to generate the OM classes.  Everything actually worked until I
compiled the project and discovered that the Base classes all had "$clo"
everywhere the column names should be.

This is an example:

    /** The value for the $clo field */
    private String $clo;
      


I assume that this is caused by some portion of the velocity processing
not properly replacing this field ($clo) with the value from the XML
schema, but I cannot understand why.

I thought it might be because I was using a schema generated by the JDBC
task, but then I imported a schema I know works fine in torque 3.0 and
the same thing happened.

I don't know a lot about velocity, or have any idea how to debug it, but
I hope there is something I can change in my build.properties file to
make it properly recognize and use the column names from the XML file.

Any ideas?

Cameron


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message