db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Klingel" <Adrian.Klin...@gpi.com>
Subject Nagging error while trying to create project-schema.xml file from Oracle DB via JDBC
Date Mon, 19 Apr 2004 18:05:49 GMT
While attempting to build Torque with Ant, I am unable to build to target
jdbc.  I have an already existing data source in an Oracle 9i Release 2
database.  I'm using Sun's J2SDK 1.4.2_04 release with the Oracle JDBC
driver for Java SDK release 1.4, or ojdbc14.jar.

I've tried just about everything, but I continue to get a
NoClassDefFoundError for java.sql.Savepoint.  Oracle SAYS they have
implemented the java.sql.Savepoint, so I'm not quite sure what's going on

I know that others have had this error before because they've attempted to
use Oracle 1.4 driver with a less-than-1.4 JDK.  Just so you know, that's
not the case here.

I also know that Oracle JDBC driver is not a complete implementation to the
JDBC spec (incomplete BLOB implementation, for example), so if something
else is missing it won't completely surprise me.

Someone must have tried this before, hopefully someone has seen the problem
or can point out the obvious thing that I may be missing.

Finally, I'm running Ant out of Eclipse 2.1.1.

Thanks for any help you can offer.

Adrian Klingel

To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org

View raw message