db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From T E Schmitz <m...@numerixtechnology.de>
Subject PostgreSQL TIMESTAMP comparison fails
Date Mon, 12 Apr 2004 22:57:59 GMT
Hello,

I created a table with a required TIMESTAMP attribute.
I selected a perviously created record via torque, then attempted DELETE 
with doDelete (obj).

doDelete does not delete the record as the following WHERE clause 
returns no results:
whereClause=BRAND_NAME='Olympus' AND TIMESTAMP={ts '2004-04-11 
17:36:51.291'}

The timestamp comparison obviously fails. (Before I had a TIMESTAMP 
column, doDelete (obj) worked fine).


Do you have any ideas why and, more importantly, is there a work-around?

PostgreSQLs TIMESTAMP type is WITH TIME ZONE. I also tried  TIMESTAMP 
WITHOUT TIMEZONE but that causes a crash.

I noticed Torque uses java.util.Date rather than java.sql.Date.

-- 


Regards,

Tarlika Elisabeth Schmitz

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message