db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From T E Schmitz <mail...@numerixtechnology.de>
Subject Re: Torque.init / setting dbcp properties fails
Date Tue, 30 Mar 2004 17:52:59 GMT
Could it be that the properties have simply been renamed / obsoloted as 
follows in commons-dbcp:

connectionWaitTimeout ==> maxWait ?
defaultMaxConnections ==> obsoleted ?
logInterval ==> obsoleted ?
maxExpiryTime ==> removeAbandonedTimeout ?

I also found mentioned that defaultMaxActive has been renamed:
defaultMaxActive ==> maxActive

I'm just guessing but in any case removing the above properties from 
Torque.properties got rid of the errors.


Regards,

Tarlika Elisabeth Schmitz


T E Schmitz wrote:

> Hello,
> 
> Torque.init causes the following errors:
> 
> ERROR [org.apache.torque.dsfactory.AbstractDataSourceFactory] - 
> (setProperty) Property: logInterval value: 0 is not supported by 
> DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
> ERROR [org.apache.torque.dsfactory.AbstractDataSourceFactory] - 
> (setProperty) Property: connectionWaitTimeout value: 10 is not supported 
> by DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
> ERROR [org.apache.torque.dsfactory.AbstractDataSourceFactory] - 
> (setProperty) Property: defaultMaxConnections value: 80 is not supported 
> by DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
> ERROR [org.apache.torque.dsfactory.AbstractDataSourceFactory] - 
> (setProperty) Property: maxExpiryTime value: 3600 is not supported by 
> DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
> ERROR [org.apache.torque.dsfactory.AbstractDataSourceFactory] - 
> (setProperty) Property: testOnBorrow value: true is not supported by 
> DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
> ERROR [org.apache.torque.dsfactory.AbstractDataSourceFactory] - 
> (setProperty) Property: validationQuery value: SELECT 1 is not supported 
> by DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
> 
> 
> My set-up:
> PostgreSQL 7.2.1, torque 3.1, Java 2 SDK 1.4.2_01, Windows 2000,
> 
> I have managed to eliminate the last two errors by using the latest 
> commons-dbcp-1.1.jar instead of the one that shipped with Torque 3.1.
> 
> I have tried various postgresql drivers but that has no effect. My 
> impression is that it has nothing to do with the database driver.
> 
> Prior database intialization with the torqe generated SQL worked fine. 
> Inserting a record into one of the tables also works despite the errors 
> during Torque.init().
> 
> I noticed somebody else posted a similar problem in December, but the 
> issue doesn't seem to have been resolved; at least it wasn't mentioned 
> in the thread. (see 
> www.mail-archive.com/torque-user@db.apache.org/msg01873.html)
> 
> 
> Any help would be much appreciated.
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message