db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caron, Roger A." <roger.ca...@pw.utc.com>
Subject Torque JNDI with Weblogic
Date Thu, 25 Mar 2004 17:44:22 GMT

> I have a JNDI connection enabled on my weblogic server.  I've specified
> the following in my torque.properties:
> 
> ===================================
> torque.database.default          = ORAT017
> torque.database.ORAT017.adapter  = oracle
> torque.database.ORAT017.driver   = oracle.jdbc.driver.OracleDriver
> 
> torque.dsfactory.ORAT017.factory=org.apache.torque.dsfactory.JndiDataSourc
> eFactory
> torque.dsfactory.ORAT017.jndi.path=ssha-datasource
> 
> torque.dsfactory.ORAT017.jndi.java.naming.factory.initial=org.apache.namin
> g.java.javaURLContextFactory
> torque.dsfactory.ORAT017.jndi.java.naming.factory.url.pkgs=org.apache.nami
> ng
> ===================================
> 
> The Weblogic datasource name is ssha-datasource.  I've tried all different
> combinations for the jndi.path including 
> java:/comp/env/jdbc/ssha-datasource
> java:/comp/env/ssha-datasource
> java:/ssha-datasource
> 
> And just about any permutaion you can imagine.
> 
> I consistently get a NullPointerException in the
> TorqueInstance.getConnection method.  What am I missing?  
> 
> Thanks.
> 
> Roger

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message