db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Göschl,Siegfried" <Siegfried.Goes...@drei.com>
Subject RE: doDelete(Businessobject) doesn't delete the record from the database
Date Wed, 11 Feb 2004 17:06:19 GMT
Hi Adrian,

I came along the same problem with an record having DATE and/or TIMESTAP with Oracle9i. 

+) There is an issue with village and Oracle9i - the hh:mm:ss are truncated

+) when you delete doDelete(BOinstance) Torque creates a WHERE clause with all fields where
the timestamps might not match

Solution is to doDelete() with the primary key - this is much more efficient anyway

Cheers,

Siegfried Goeschl



-----Original Message-----
From: Tillich, Adrian [mailto:Adrian.Tillich@tui.de]
Sent: Wednesday, February 11, 2004 5:50 PM
To: 'Apache Torque Users List'
Subject: doDelete(Businessobject) doesn't delete the record from the
database


Hi Folks,

I've just realized that Torque simply doesn't always delete records when I
call something like
	BusinessobjectPeer.doDelete(BOinstance);

What I basically do is 
* create a new record, save it, 
* then reuse the same instance to do some changes (and save them to the DB
of course),
* and afterwards I delete the object (still reusing the same instance).
Is there a problem, reusing the object?
I'm a bit surprised because the update always works and I don't know how to
fix the problem.

Hope someone can help me.

Greetings,
Adrian



---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message