db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Moore, Richard" <Richard.Mo...@logistics.nhs.uk>
Subject cannot use 2 connections
Date Wed, 04 Feb 2004 11:58:33 GMT
Hello,

 

I am using jetspeed/turbine/torque, my default connection works fine but I
am having a problem using a second connection. My Torque.properties contains
:

 

torque.database.default=default

### torque.database.default.adapter=hypersonic

torque.database.default.adapter=mysql

torque.database.trdb.adapter=oracle

### torque.database.default.adapter=mssql

 

##

## Using torque's old pool

##

### torque.dsfactory.default.connection.driver = org.hsqldb.jdbcDriver

### torque.dsfactory.default.connection.url =
jdbc:hsqldb:${webappRoot}/WEB-INF/db/jetspeed

### torque.dsfactory.default.connection.user = sa 

### torque.dsfactory.default.connection.password = 

 

torque.dsfactory.default.factory=org.apache.torque.dsfactory.TorqueDataSourc
eFactory

# The number of database connections to cache per ConnectionPool instance
(specified per database)

torque.dsfactory.default.pool.defaultMaxConnections=10

torque.dsfactory.default.pool.maxExpiryTime=3600

torque.dsfactory.default.pool.connectionWaitTimeout=10

### MySQL

torque.dsfactory.default.connection.driver = org.gjt.mm.mysql.Driver

torque.dsfactory.default.connection.url =
jdbc:mysql://localhost:3306/turbine

torque.dsfactory.default.connection.user =  ****

torque.dsfactory.default.connection.password = ****

 

torque.dsfactory.trdb.factory=org.apache.torque.dsfactory.TorqueDataSourceFa
ctory

# The number of database connections to cache per ConnectionPool instance
(specified per database)

torque.dsfactory.trdb.pool.defaultMaxConnections=10

torque.dsfactory.trdb.pool.maxExpiryTime=3600

torque.dsfactory.trdb.pool.connectionWaitTimeout=10

### Oracle

torque.dsfactory.trdb.connection.driver=oracle.jdbc.driver.OracleDriver

torque.dsfactory.trdb.connection.url=jdbc:oracle:thin:@194.155.160.252:1521:
TRDB

torque.dsfactory.trdb.connection.username=****

torque.dsfactory.trdb.connection.password=****

 

 

When I try and get a connection to trdb from my portlet, I get the following
error :

 

There was no DataSourceFactory configured for the connection trdb

java.lang.NullPointerException: There was no DataSourceFactory configured
for the connection trdb

 

I cannot figure this out - any ideas?

 

Many thanks,

 

Richard.

 


This e-mail and any attachments hereto are:

-strictly confidential and intended solely for the addressee. If you are
not the intended addressee, you must not disclose, forward, copy, or take any 
action in reliance on this e-mail or attachments. If you have received this
e-mail in error, please notify NHS Logistics sender as soon as possible.

-not intended to create contractual relations or legal obligations binding
on NHS Logistics and no action may be taken in reliance on this e-mail and
any attachments hereto unless the contents are confirmed by letter.

Addressees should check all attachments for viruses. NHS Logistics makes no
representations as regards the absence of viruses in attachments to this
e-mail.


Mime
View raw message