db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mo...@physics.gmu.edu
Subject Re: Exception thrown by generator.parse
Date Wed, 11 Feb 2004 14:56:49 GMT
Thank you very much Damien. It works. Dint realize that could be the issue.


--Mohan


> all you need to do is change integer to INTEGER, check out the generator
> dtd at
> http://db.apache.org/torque/generator/database.dtd.txt that will help in
> the future
>
> Damien
>
> Damien Corbishley
> Senior Software Developer
> Professional Services
>
> Creators of Omvia, an integrated approach to next generation
> communication applications.
> Visit us at:      http:// www.intervoice.com
> Direct Line :   +44 (0) 161 495 1268
> Main Office:   +44 (0) 161 495 1000
>
>
> This email and any files transmitted are intended for the addressee only
> - it is private and confidential.  If you have received this mail in
> error please notify the sender and immediately delete the email.
> Professional Services  is a division of Intervoice, whose registered
> office is: Brite Court, Park Road, Gatley, Cheshire, SK8 4HZ, UK. (c)
> 2003 Intervoice. All rights reserved.
>
>
>>>> mohan@physics.gmu.edu 22:12:05 10 February 2004 >>>
> Hi Guys
> I am using the torque 3.1. I have the following schema
>
> <table name="USABO_STUDENT">
>
>     <column name="USABO_SID" required="true" primaryKey="true"
> type="integer" />
>     <column name="FIRST_NAME" required="true"  type="VARCHAR" size="50"
> />
>     <column name="LAST_NAME" required="true" type="VARCHAR" size="50" />
> <column name="PHONE" required="true" type="VARCHAR" size="30" />
> <column name="TEACHER_ID" required="true" type="integer" />
>     <column name="STATUS" required="true" type="VARCHAR" size="30" />
> <column name="YEAR" type="VARCHAR" size="4" />
>
>     <foreign-key foreignTable="PERSON">
>         <reference local="TEACHER_ID" foreign="ID" />
>     </foreign-key>
>
> </table>
>
> I get an error only when i have this table in the schema other wise the
> build is successful. I do not understand what the reason is for this.
> The
> error is as follows:
>
> Exception thrown by 'generator.parse'. For more information consult the
> velocity log, or invoke ant with the -debug flag.When i used the debug
> flag i get these exceptions at the end
>
> Exception thrown by 'generator.parse'. For more information consult the
> velocity log, or invoke ant with the -debug flag.
>         at
> org.apache.velocity.texen.ant.TexenTask.execute(TexenTask.java:564)
>         at org.apache.tools.ant.Task.perform(Task.java:341)
>         at org.apache.tools.ant.Target.execute(Target.java:309)
>         at org.apache.tools.ant.Target.performTasks(Target.java:336) at
> org.apache.tools.ant.Project.executeTarget(Project.java:1339) at
> org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:397) at
> org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:143)
>         at org.apache.tools.ant.Task.perform(Task.java:341)
>         at org.apache.tools.ant.Target.execute(Target.java:309)
>         at org.apache.tools.ant.Target.performTasks(Target.java:336)
>
>
>
> Caused by: org.apache.velocity.exception.MethodInvocationException:
> Invocation of method 'parse' in  class
> org.apache.velocity.texen.Generator
> threw exception class
> org.apache.velocity.exception.MethodInvocationException : Invocation of
> method 'get' in  class java.util.Properties threw exception class
> java.lang.NullPointerException : null
>         at
> org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:309)
>         at
> org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:207)
>         at
> org.apache.velocity.runtime.parser.node.ASTReference.value(ASTReference.java:357)
>         at
> org.apache.velocity.runtime.parser.node.ASTSetDirective.render(ASTSetDirective.java:135)
>         at
> org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:271)
>         at org.apache.velocity.Template.merge(Template.java:296)
>         at org.apache.velocity.texen.Generator.parse(Generator.java:425)
> at org.apache.velocity.texen.Generator.parse(Generator.java:361)
> at sun.reflect.GeneratedMethodAccessor30.invoke(Unknown Source)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:324)
>         at
> org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:260)
>         at
> org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:207)
>         at
> org.apache.velocity.runtime.parser.node.ASTReference.render(ASTReference.java:250)
>
>
> Please help me if any one can figure out the reason for this. This
> happens
> only when the schema has this table. But when i remover this table from
> the schema the rest of the schema works just fine.
>
>
> --Mohan
>
>
>
>
>
>
>
> --------------------------------------------------------------------- To
> unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-user-help@db.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message