db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Giulio Vezzelli" <giulio.vezze...@infolog.it>
Subject R: doDelete(Object) doesn't work ?
Date Wed, 03 Dec 2003 10:09:59 GMT
I just found the solution.

xxxxPeer.doDelete(myBusinessObject.getPrimaryKey())

Works fine.

I think doDelete(obj) didn't work because it tried to build a where clause with the object
fields, and one of the fields got screwed up because of special characters in it.

Giulio Vezzelli
Infolog S.r.l.
Via Alfieri, 28
Modena - 41100
Telefono : +39-059-822446
Sito web : http://www.infolog.it
E-mail : giulio.vezzelli@infolog.it
 
 

> -----Messaggio originale-----
> Da: Giulio Vezzelli 
> Inviato: mercoledì 3 dicembre 2003 10.59
> A: torque-user@db.apache.org
> Oggetto: doDelete(Object) doesn't work ?
> 
> Hi,
>  
>     I tried to use xxxxPeer.doDelete(myBusinessObject), but 
> it doesn't seem to work.
> I see a doDelete debug output in Tomcat's console, which 
> specifies a where clause with all that objects' fields, but 
> the object isn't deleted.
>  
> Doesn't it work ?
>  
> which doDelete does effectively work ?!?
>  
> 
> Thanks!!
>  
> Giulio Vezzelli
> Infolog S.r.l.
> Via Alfieri, 28
> Modena - 41100
> Telefono : +39-059-822446
> Sito web : http://www.infolog.it <http://www.infolog.it/> 
> E-mail : giulio.vezzelli@infolog.it
>  
>  
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message