db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Leng <wl...@10.1.7.10>
Subject Re: Help Plsssssssssssss
Date Sat, 06 Dec 2003 02:22:20 GMT
try the attached village.jar.

Sonu Vijay wrote:

>Guys,
>I"m about to go mad on this on, so pls give me ur
>ideas. As some of you might know since yesterday I've
>been trying to make the Torque generated Java Classes
>to work with DB2400 and I can do selects and deletes
>but can't do Inserts and I'm getting the following
>exception every time I try an Insert:
>
>java.sql.SQLException: [SQL0104] Token ) was not
>valid. Valid tokens: DAY PATH YEAR LABEL MONTH OPTION
>RESULT CONNECTION TRANSACTION.
>
>Now I tried my level best to print the Insert queries
>without getting into Torque code but it didn't work. I
>also tried the spy programs suggested by some guys in
>the list but still got nothing.
>
>Maybe that was too much to handle for an Entry level
>programmer.
>
>So I downloaded the Torque code and messed around with
>it. Then I downloaded all the village code and tried
>to put debugging statements in it.
>
>So here is what I have found. The actual queries are
>being executed in the village code and I could get the
>Insert query also. In the village code they check if a
>column in read only ( resultSetMetaData.isReadOnly() )
>and my columns come as readOnly, so that's where the
>trouble is.
>
>Now I can't see a damn reason why they are read only.
>I can run SQL Inserts from my AS400 operations
>navigator with the same USERID/PASSWORD that I'm
>supplying to the Torque java classes.
>
>So I would really really appreciate any ideas you
>might have abt the situation. If you need any more
>information I'll be happy to provide that.
>
>Thanks
>
>Vijay
>
>
>
>
>
>
>
>__________________________________
>Do you Yahoo!?
>Free Pop-Up Blocker - Get it now
>http://companion.yahoo.com/
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
>For additional commands, e-mail: torque-user-help@db.apache.org
>
>  
>


Mime
View raw message