db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Krabbenbos <jan.krabben...@planet.nl>
Subject Re: default="" generates 'varname = ;'
Date Tue, 02 Dec 2003 22:00:12 GMT
Hi Gary,

Thanks for the information. I checked the table and there is only one column 
nullable, which is a timestamp. I have not checked your idea of a nullable 
column yet (I'm busy too ;-)), but it might be the problem. 

I'll have a look at the XSLT script as soon as possible.

On Wednesday 26 November 2003 23:13, Gary Shea wrote:
> Hi Jan --
>
> I didn't look closely at your example (busy! busy!  eek!) but I believe
> I know the problem.  You have a nullable integer value somewhere.
> Torque ALWAYS provides a default value, nullable or not.  In this case
> the value is "", which somehow gets turned into the result you're
> seeing.  I see this so much I have an XSLT script for fixups, it is
> attached, hope it is some use.  Also, if you want to improve the script
> that would be great as I'm pretty much an idiot about XSLT!
>
> Regards,
>
>         Gary
>
> p.s. There's a section in the script that changes *BINARY to
> LONGVARCHAR; my particular application has no true binary fields but
> uses *BLOB types to avoid the string-specific rules in *TEXT.
>

-- 
Met vriendelijke groet,

Jan Krabbenbos

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message