db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramesh Sabeti" ...@reazon.com>
Subject JDBC2 pool and Oracle
Date Thu, 11 Dec 2003 02:17:39 GMT
Hi all,
I'm trying to get jdbc2 pool work with Oracle and it's not happening for
me...
 
Here's my old settings, and it was working fine during development:
 
torque.dsfactory.default.factory=org.apache.torque.dsfactory.TorqueDataS
ourceFactory
torque.dsfactory.default.pool.defaultMaxConnections=10
torque.dsfactory.default.pool.maxExpiryTime=3600
torque.dsfactory.default.pool.connectionWaitTimeout=10
 
But when it's deployed to production, we get the following error
message: 
 
ORA-00020: maximum number of processes (50) exceeded
 
 
Seems like Oracle doesn't expire connections.  Some posting suggested a
problem with Oracle 9.2 JDBC driver.  So I'm trying to use jdbc2 pool
and changed the settings to this:
 
torque.dsfactory.default.factory=org.apache.torque.dsfactory.Jdbc2PoolDa
taSourceFactory
torque.dsfactory.default.pool.defaultMaxActive=10
torque.dsfactory.default.pool.testOnBorrow=true
torque.dsfactory.default.pool.validationQuery=SELECT 1
 
Now, nothing works, even Tomcat.  When I deploy the app and restart
Tomcat, it first opens 14 connections to Oracle, and then hangs Tomcat
right when Torque starts to initialize.  Any ideas?  Does anyone have a
different jdbc2 pool setting for Oracle?
 
Thanks in advance,
 
Ramesh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message