db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amine Bousta" <abou...@lxsolutions.com>
Subject RE: Pb with dbcp
Date Thu, 13 Nov 2003 08:37:30 GMT
Thank you very much :)

In fact I had two kind of errors :
1. Properties initialisations gave me warnings
2. Tomcat cannot instantiate MapBuilder

For the first problem you solved, I'd be very happy if you could send me
your Torque.properties or an exemple.
I'm surprised that the Torque Properties file given by Torque 3.1 is wrong
but may be 3.1 is not stable yet.

For the second problem, I fixed it by moving my dbcp jars from common/lib
into WEB-INF/lib !
Then I decided to move all of my jars from common/lib into web-inf/lib.
And now, even if I get warnings still about properties initialisation,
everything works! Strange...

Do you know if there are rules to respect with jars location in Tomcat to
make Torque work?
Because now, I have a lot of jars in common/lib, web-inf/lib and Torque/lib
(for generation). Everything seems unorganized and unstable to me...

Thanks
Amine


-----Message d'origine-----
De : Steve Hansen [mailto:steve.hansen@sinex.com]
Envoyé : jeudi 13 novembre 2003 03:58
À : Apache Torque Users List
Objet : Re: Pb with dbcp


Hello Amine,

I've been working on a similar error.  I've used Torque 3.0 now I have a
new project so I'm setting up 3.1.  In the Torque.properties I decided
to set up the suggested commons-dpcp. I used the Default section, filled
in my driver, jdbc and login info and came up with the error you
describe.

Then I went to the Java-Doc for SharedPoolDataSource and there is no
property logInterval!  I removed that part of the default and one of the
errors were removed. I had a error referring to defaultMaxConnections
and changed it to maxActive (this is in the Java-doc).  I set my Log4j
level to debug and I can see that the SharedPoolDataSource is happy with
these changes..

hth

On Wed, 2003-11-12 at 08:42, Amine Bousta wrote:
>
> Hello
>
> I'm trying to make Torque working with Tomcat.
> It seems I have a pb with the pool manager because I can't do a "save()".
> When I try to do that, Tomcat logs a lot of debugs.
> It says :
> GRAVE: property: logInterval value: 0 is not supported byDataSource:
> org.apache.commons.dbcp.datasources.SharedUserPoolDataSource
>
> I have this error for all of my Torque properties!
>
> Then I have a ClassNotFoundException because BasePeer.MapBuilder failed
> trying to instantiate my torque.map.AgentMapBuilder (Agent is one of my
> torque objects).
>
> It's been hours and hours I try to find a workaround. I didn't find
anything
> on the net about it.
>
> The strangest thing is that I have another project on the same tomcat and
> this one works!
> I put the commons-dbcp jar on common/lib... Does it have a relation
between
> this and my pb?
> Do you think I may have a buggy dbcp jar??
>
> If anybody could help I'd be very happy !!
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-user-help@db.apache.org
>
>
--
Steve Hansen
Solutions Engineer
Sinex Aviation Technologies
steve.hansen@sinex.com


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org





---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message