db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Diachuk <rdiac...@enrolnet.com>
Subject Connection object null
Date Thu, 02 Oct 2003 17:39:14 GMT
Hi y'all. I get the following error when I first 
try to access the db.

Connection object was null. This could be due to a 
misconfiguration of the DataSourceFactory.


I'm using the torque connection pool with the 
following in the Torque.properties file.


torque.database.default=mydb 
torque.database.mydb.adapter=mysql 

## Using torque's old pool 
torque.dsfactory.mydb.factory=org.apache.torque.dsfa
ctory.TorqueDataSourceFactory 
torque.dsfactory.mydb.pool.defaultMaxConnections=10 
torque.dsfactory.mydb.pool.maxExpiryTime=3600 
torque.dsfactory.mydb.pool.connectionWaitTimeout=10 
torque.dsfactory.mydb.connection.driver=org.gjt.mm.m
ysql.Driver 
torque.dsfactory.mydb.connection.url=jdbc:mysql://lo
calhost/mydb 
torque.dsfactory.mydb.connection.user=root 
torque.dsfactory.mydb.connection.password=dagmar

The crazy part is that my application works on the 
windows box that I developed it on but after 
deployment on a linux server I cannot access the db 
through torque. (db access is fine through jstl so 
I know the user and password values are fine). I'm 
also sure that the path to the Torque.properties 
file that I am using on the linux server is 
correct - I get a file.io exception if I rename the 
file.

thanks,
Randy

 
 


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message