db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keeney, Thomas" <Keen...@SEC.GOV>
Subject RE: MySQL autoincrement not working
Date Wed, 03 Sep 2003 17:53:23 GMT
Chris,

Try autoIncrement instead of autoincrement.

Tom

-----Original Message-----
From: Chris Huisman [mailto:chuisman@chenomx.com]
Sent: Wednesday, September 03, 2003 11:31 AM
To: Apache Torque Users List
Subject: MySQL autoincrement not working 


Hello,

I have just upgraded to version 3.1, and in updating my schema per:
     TRQS178: use sql autoincrement only if idMethod native.  So you 
have to set idMethod="native" (table) plus     autoincrement="true" 
(column) to generate the autoincrement code in your sql.
my tables primary keys are not longer being autoincremented. 

The following is an example table:
   <table name="USER" description="A collection of all users" 
idMethod="native">
        <column name="USER_ID" primaryKey="true" required="true" 
type="INTEGER" autoincrement="true"/>
        <column name="EMAIL_ADDRESS" required="true" size="30" 
type="VARCHAR"/>       
        <column name="PASSWORD" required="true" size="12" type="VARCHAR"/>
        <column name="PERMISSIONS" required="true" size="12" 
type="VARCHAR"/>
        <unique>
              <unique-column name="EMAIL_ADDRESS"/>
        </unique>
    </table>

What am I doing wrong?

chris.


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message