db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gedin Frederic <frederic.ge...@jaluna.com>
Subject ColumnMap.getSize() always returns 0
Date Fri, 26 Sep 2003 22:28:53 GMT
Hi


I tried to retrieve the size of a field using 
getTableMap().getColumnName("FIELD").size().
The return value is zero.

So I made the following test:
            ColumnMap[] cols = getTableMap().getColumns();
            for (int i = 0; i < cols.length; i++) {
                System.out.println("cols[i].getColumnName() + ": size = 
" + cols[i].getSize());
            }

And, I realized that, for all columns, the getSize() function always 
returns 0.
Looking deeper into the generated map builder, I saw that the 
TableMap.addColumn function is always invoked with no defined size, 
leading to a default size being set to 0.

Computing the size of a field using the getSize() method worked for me 
in torque 3.0.2.
As I took benefit of the migration to torque 3.1 to make significant 
refactoring, maybe I introducd a bug in my own code.  However, I suspect 
that somehting has changed in this area but I was not able to detect where.

Any hint?

Frederic



---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message