db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frederic.Ge...@Jaluna.COM
Subject Problem to migrate to Torque 3.1
Date Fri, 12 Sep 2003 22:32:01 GMT


Hello


I am facing a very strange problem in my application which was working well with
Torque 3.0.2.
The test suite initialization log shows an error witht he database connection
pooling which I do not understand:

Torque.properties:
torque.dsfactory.smm.factory=org.apache.torque.dsfactory.SharedPoolDataSourceFactory
torque.dsfactory.smm.pool.defaultMaxActive=30
torque.dsfactory.smm.pool.testOnBorrow=true
torque.dsfactory.smm.pool.validationQuery=SELECT 1
torque.dsfactory.smm.connection.driver = org.gjt.mm.mysql.Driver
torque.dsfactory.smm.connection.url = jdbc:mysql://127.0.0.1/smm

The log file shows:
[ERROR] AbstractDataSourceFactory - -Property: logInterval value: 0 is not
supported by DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
[ERROR] AbstractDataSourceFactory - -Property: connectionWaitTimeout value: 10
is not supported by DataSource:
org.apache.commons.dbcp.datasources.SharedPoolDataSource
[ERROR] AbstractDataSourceFactory - -Property: defaultMaxConnections value: 80
is not supported by DataSource:
org.apache.commons.dbcp.datasources.SharedPoolDataSource
[ERROR] AbstractDataSourceFactory - -Property: maxExpiryTime value: 3600 is not
supported by DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
[DEBUG] AbstractDataSourceFactory -
-applyConfiguration(org.apache.commons.configuration.BaseConfiguration@c623af,
org.apache.commons.dbcp.datasources.SharedPoolDataSource@3cc262)
[ERROR] AbstractDataSourceFactory - -Property: defaultMaxActive value: 10 is not
supported by DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource
[DEBUG] ConvertUtils - -Convert string 'true' to class 'boolean'
[ERROR] AbstractDataSourceFactory - -Property: testOnBorrow value: true is not
supported by DataSource: org.apache.commons.dbcp.datasources.SharedPoolDataSource

It seems that the configuration looks for TorqueDataSourceFactory parameters
while I am using SharedPoolDataSourceFactory.
Of course, this results in a NullPointerException when I try to save something
in the database

What is more strange is that an other application has been migrated without any
problem.

Any help please?

Thank you


Frederic 


---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message