db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giulio Vezzelli <giulio.vezze...@infolog.it>
Subject Re: problems with torque at runtime
Date Fri, 22 Aug 2003 00:29:42 GMT
Johannes Plachy wrote:

>Cameron,
>
>Torque always claims to be initialized correctly ( Torque.isInit()
>returns true) and the 
>initialization itself is done without error message.
>
>Currently I switched to Tomcat-managed Datasources and pass a Connection
>object to each Torque-peer class method.
>This works fine, but I quess is not the cleanest solution.
>
>Johannes
>
>( following my init servlet code )
>
Hi Johannes,

I get the same error (connection object was null) if I use Torque in a 
webapp and I reload it from the Tomcat manager. I think the issue is 
re-initializing Torque without properly shutting it down (if I tried all 
methods related to shutdown). If I restart the whole container (Tomcat, 
in this case) the webapp works fine again. I don't know if it helps, but 
it may be a similar problem (and the solution might solve mine too!)

Greetings,

Giulio Vezzelli

Infolog S.r.l.
Via Alfieri, 28
Modena - 41100
Telefono : +39-059-822446
Web : http://www.infolog.it
E-mail : giulio.vezzelli@infolog.it




---------------------------------------------------------------------
To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
For additional commands, e-mail: torque-user-help@db.apache.org


Mime
View raw message