db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Dietz <jo...@purplebear.com>
Subject Torque under JRun and Cold Fusion
Date Wed, 07 May 2003 23:10:06 GMT
I may be the only person running in this particular environment, is  
anyone else?

I'm building an application with a Cold Fusion (I have Cold Fusion  
developers) front end that calls Java and using Torque for database  
persistence.
Is anyone else doing anything like this?

I'm using JRun as my J2EE server. I've put my JAR and all of the Torque  
JARs in:
[JRUN Home]/server/lib

When I try to run my code that calls the code from Cold Fusion, I get  
the exception at the end of this post.
This happens during the call to initialize the Torque engine. Here's  
the strange thing. If I call the
exact some code from a JSP on the same server, it works perfectly. If I  
then try to rerun the CF pages
with the same code, then they work, until I restart the server. Then  
they fail again.

I've seen some reported problems with log4j with JRUN/CFMX and I wonder  
if this is related. Any ideas?

[1]org.apache.commons.logging.LogConfigurationException:  
java.lang.ClassCastException
at org.apache.commons.logging.LogFactory.newFactory(LogFactory.java:558)
at org.apache.commons.logging.LogFactory.getFactory(LogFactory.java:279)
at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:390)
at  
org.apache.commons.beanutils.ConvertUtils.<clinit>(ConvertUtils.java:318 
)
at  
org.apache.torque.dsfactory.AbstractDataSourceFactory.setProperty(Abstra 
ctDataSourceFactory.java:119)
at  
org.apache.torque.dsfactory.TorqueDataSourceFactory.initCPDS(TorqueDataS 
ourceFactory.java:134)
at  
org.apache.torque.dsfactory.TorqueDataSourceFactory.initialize(TorqueDat 
aSourceFactory.java:108)
at org.apache.torque.Torque.initDataSourceFactories(Torque.java:323)
at org.apache.torque.Torque.initialize(Torque.java:237)
at org.apache.torque.Torque.init(Torque.java:406)

John Dietz


Mime
View raw message