db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thijs Verhagen <thijsverha...@mac.com>
Subject Re: Resource not found during create-db
Date Sat, 22 Mar 2003 23:11:09 GMT
I had this once and got rid of it by inserting

torque.useClasspath = true

in build.properties for build-torque.xml

This setting is used by the ant tasks of torque 
(org.apache.torque.task).
Check if the velocity templates (.vm) files are in your torque.jar.

gr.
Thijs




Gabriel Bauman heeft op vrijdag, 21 maa 2003 om 20:42 
(Europe/Amsterdam) het volgende geschreven:

> Hi!
>
> I am currently having issues running the create-db target. I'm using 
> the Torque Maven plugin from cvs head.
>
> This looks like some kind of paths problem, velocity templates not 
> being loaded from the torque jar or something. I generate the SQL for 
> table creation with no problems, but create-db fails.
>
> My output is below. I would really, really appreciate any help.
>
> Gabe Bauman
>
> --------------------------------------------------
>
> D:\Software\maven\bin\maven.bat torque:create-db
>  __  __
> |  \/  |__ Jakarta _ ___
> | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> |_|  |_\__,_|\_/\___|_||_|  v. 1.0-beta-9-SNAPSHOT
>
> torque:init:
>
> torque:create-db:
>     [torque-data-model] Using classpath
>     [torque-data-model] Generating to file 
> D:\work\projects\hosting\target\classes\sql\create-db.sql
>
> Total time:  8 seconds
>
> BUILD FAILED
> Resource not found. For more information consult the velocity log, or 
> invoke ant with the -debug flag.
> --------------------------------------------------
>
> And in the Velocity log:
>
> --------------------------------------------------
> 2003-03-21 11:19:37,076 - Default ResourceManager initializing. (class 
> org.apache.velocity.runtime.resource.ResourceManagerImpl)
> 2003-03-21 11:19:37,086 - Resource Loader Instantiated: 
> org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader
> 2003-03-21 11:19:37,086 - ClasspathResourceLoader : initialization 
> starting.
> 2003-03-21 11:19:37,086 - ClasspathResourceLoader : initialization 
> complete.
> 2003-03-21 11:19:37,086 - ResourceCache : initialized. (class 
> org.apache.velocity.runtime.resource.ResourceCacheImpl)
> 2003-03-21 11:19:37,086 - Default ResourceManager initialization 
> complete.
> ...snip...
> 2003-03-21 11:19:37,487 - ResourceManager : unable to find resource 
> 'VM_global_library.vm' in any resource loader.
> 2003-03-21 11:19:37,487 - Velocimacro : error using  VM library 
> template VM_global_library.vm : 
> org.apache.velocity.exception.ResourceNotFoundException: Unable to 
> find resource 'VM_global_library.vm'
> ...snip...
> 2003-03-21 11:19:37,547 - ResourceManager : unable to find resource 
> 'sql/db-init/Control.vm' in any resource loader.
> --------------------------------------------------
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: torque-user-unsubscribe@db.apache.org
> For additional commands, e-mail: torque-user-help@db.apache.org
>


Mime
View raw message