db-torque-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nader S. Henein" <...@bayt.net>
Subject BasePeer.MapBuilder failed trying to instantiate
Date Thu, 27 Feb 2003 11:46:04 GMT
Dear All,

I realize that this issue has cropped up a few times on the turbine-torque
archive and I do realize some people have written comments about this, but I
have no idea why I'm getting this error.

ERROR - BasePeer.MapBuilder failed trying to instantiate:
com.bayt.torque.map.BytLearningProvidersMapBuilder
java.lang.ClassNotFoundException:
com.bayt.torque.map.BytLearningProvidersMapBuilder
	at java.net.URLClassLoader$1.run(URLClassLoader.java:198)
	at java.security.AccessController.doPrivileged(Native Method)

This is what I've done:
- I've tested my application as a standalone app, so I know that it works
and that my Torque.properties file is ok.
- I've also setup the initServlet to initialize my application and I'm
fairly confident that it's initializing Torque correctly.
- I also have every jar under the sun that torque could be using in resin's
path (no duplicates)
- The map files are there at the correct location, (the standalone app
works)
- It's definitely something with the setup of torque on a webserver, I've
tried Orion 1.5.4 and I've moved to Resin 2.1.7 and still the same issue


I do not consider myself an idiot but I believe that it's a case of not
seeing the trees, because I'm too close to the forest.

HELP


Nader S. Henein
Senior Web Dev


Mime
View raw message